[Download Manager] Confirmation screen is displayed once for each selected file

VERIFIED FIXED in 1.4 S2 (28feb)

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: rafael.marquez, Assigned: crdlc)

Tracking

unspecified
1.4 S2 (28feb)
Other
Other
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*Procedure
1. Opening Settings app
2. Opening Donwloads list (There are 2 or more files in the list)
3. Press Edit button
4. Press select all button 
5. Press Delete button

*Actual Result
Confirmation screen is displayed once for each selected file. If we have 100 files, we must confirm the removal 100 times

*Expect Result
If you select 2 or more files. Only a confirmation screen appears.

This case is not defined by UX in "DM_settingsDrawerv0.14.pdf". Please can you check this case and update the document.
(Reporter)

Updated

5 years ago
Blocks: 926955
Flags: needinfo?(fdjabri)
Whiteboard: [systemsfe]
(Assignee)

Comment 1

5 years ago
We are going to work on it as soon as we have the wireframe, gracias Rafa
(Assignee)

Updated

5 years ago
blocking-b2g: --- → 1.4?
We definitely can't ship download manager without this fixed.

Francis will provide an update to clarify the expected behavior.  
Just a note, while we're blocking on this, we decided not to risk 1.4 if download manager and the child bugs aren't ready in time.  We'll evaluate that in the final sprint.
blocking-b2g: 1.4? → 1.4+
In the case of multiple files, a single confirmation dialog should be shown. 

Instead of showing the text: "Delete <filename>?", the confirmation should display: "Delete <n> files?", where n is the number of files selected. I'll update the spec.
Flags: needinfo?(fdjabri)
(Assignee)

Updated

5 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Created attachment 8379683 [details]
16509.html
Attachment #8379683 - Flags: review?(kaze)
Attachment #8379683 - Flags: review?(francisco.jordano)
Comment on attachment 8379683 [details]
16509.html

LGTM, tested on the phone and working perfectly.

Thanks Cristian!
Attachment #8379683 - Flags: review?(francisco.jordano) → review+
(Assignee)

Comment 6

5 years ago
ok, thanks a lot mate
Comment on attachment 8379683 [details]
16509.html

Looks good to me, too. Please check my nit on your PR.
Attachment #8379683 - Flags: review?(kaze) → review+
Target Milestone: --- → 1.4 S2 (28feb)
(Assignee)

Comment 8

5 years ago
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/221466ded6a14ca42fd34c1544ec17fa8549fcaa
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

5 years ago
Verified in master(1.4) branch
Status: RESOLVED → VERIFIED
Comment on attachment 8379683 [details]
16509.html

r- from the l10n side, we'll need plural support for "delete n messages" for non-English languages for which different plural forms exist above 2.
Attachment #8379683 - Flags: review-
(Assignee)

Comment 11

5 years ago
(In reply to Axel Hecht [:Pike] from comment #10)
> Comment on attachment 8379683 [details]
> 16509.html
> 
> r- from the l10n side, we'll need plural support for "delete n messages" for
> non-English languages for which different plural forms exist above 2.

Fill a bug to implement it and please explain there what it is because sadly I don't have idea.

PS: Messages are always 2 or more.

Updated

5 years ago
Blocks: 977627
(In reply to Cristian Rodriguez (:crdlc) from comment #11)
> Fill a bug to implement it and please explain there what it is because sadly
> I don't have idea.
> 
> PS: Messages are always 2 or more.

Filed bug 977627
OMG, I missed that. Thanks for the good catch, Pike.
(In reply to Cristian Rodriguez (:crdlc) from comment #11)
> Messages are always 2 or more.

A few locales (e.g. Arabic) have a specific plural rules for 2.
More generally, we should *always* think of a generic plural rules in such cases.
(Assignee)

Comment 15

5 years ago
Now I am understand, I didn't know :( Sorry
status-b2g-v1.4: --- → fixed
You need to log in before you can comment on or make changes to this bug.