All users were logged out of Bugzilla on October 13th, 2018

Tab shows iframe's favicon instead of the top frame's favicon

VERIFIED FIXED in Firefox 30

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: billm)

Tracking

({regression})

Trunk
Firefox 30
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox30 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
I have a bugzilla tab with a TBPL iframe that shows the TBPL favicon instead of the bugzilla favicon. I noticed this first after updating to today's Nightly. I suspect this might be a regression of bug 961529. Here's a link to a bug where that is happening with the BugzillaJS add-on installed that turns TBPL links into iframes:

https://bugzilla.mozilla.org/show_bug.cgi?id=967766

It's probably not too hard to create an actual small test page to demonstrate the issue but OTOH this is probably equally easy to fix.

Updated

5 years ago
status-firefox30: --- → affected
tracking-firefox30: --- → ?
Created attachment 8373523 [details] [diff] [review]
favicon-fix

Thanks for the testcase. I really should have been more careful here. Looking at the code before my patch, it's pretty clear that the handlers for favicons, feeds, and search engines all want to ignore subframes. This patch just adds a central check.
Assignee: nobody → wmccloskey
Status: NEW → ASSIGNED
Attachment #8373523 - Flags: review?(felipc)
Attachment #8373523 - Flags: review?(felipc) → review+
https://hg.mozilla.org/mozilla-central/rev/650fb3d50b5d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
(Reporter)

Updated

5 years ago
Duplicate of this bug: 970976
(Reporter)

Updated

5 years ago
Duplicate of this bug: 970986
(Reporter)

Updated

5 years ago
status-firefox30: affected → fixed
tracking-firefox30: ? → ---
I should probably write a test for this.
Flags: needinfo?(wmccloskey)
Filed bug 971336 for the test.
Flags: needinfo?(wmccloskey)

Updated

5 years ago
Keywords: verifyme

Comment 9

5 years ago
Verified on nightly 20140224180004 build
Status: RESOLVED → VERIFIED
status-firefox30: fixed → verified
Flags: in-testsuite+
Keywords: verifyme
QA Contact: ananuti
You need to log in before you can comment on or make changes to this bug.