Intermittent | test_browserElement_NoPref.html | Should not send mozbrowserloadstart event.

RESOLVED FIXED in Firefox 28

Status

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: cbook, Assigned: kanru)

Tracking

({intermittent-failure})

unspecified
1.4 S2 (28feb)
x86
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox28 fixed, firefox29 affected, firefox30 fixed, firefox-esr24 unaffected, b2g-v1.2 affected, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v1.4 fixed)

Details

()

Attachments

(3 attachments)

b2g_emulator_vm mozilla-inbound opt test mochitest-5 on 2014-02-10 04:40:17 PST for push 5741926de900

slave: tst-linux64-spot-193

https://tbpl.mozilla.org/php/getParsedLog.php?id=34414170&tree=Mozilla-Inbound



283 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/browser-element/mochitest/test_browserElement_NoPref.html | Should not send mozbrowserloadstart event.
This is a pretty frequent failure that started in the last couple days. Can we please get someone to look into it?
Flags: needinfo?(overholt)
Component: Mochitest → General
Product: Testing → Firefox OS
Version: Trunk → unspecified
Another test that's failing more often than it's passing and contributing to mochitest-5 being nearly perma-orange. Disabled.

https://hg.mozilla.org/integration/b2g-inbound/rev/4a1fc1dc347b
Whiteboard: [tests disabled on B2G][leave open]
"load" event could fire before the preferences are actually set. Using "testready" is also consistent with other browser-element tests.

https://tbpl.mozilla.org/?tree=Try&rev=0bdffc726185
Assignee: nobody → kchen
Attachment #8378174 - Flags: review?(fabrice)
Flags: needinfo?(overholt)
Comment on attachment 8378174 [details] [diff] [review]
Wait "testready" instead of "load" event

Review of attachment 8378174 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #8378174 - Flags: review?(fabrice) → review+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [tests disabled on B2G][leave open]
Target Milestone: --- → 1.4 S2 (28feb)
Hmm.. two more fails after the fix? Maybe the patch doesn't fix it completely :/
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #8381212 - Flags: review?(fabrice)
Depends on: 976520
try server with many retriggers is looking good!
Comment on attachment 8381211 [details] [diff] [review]
Rename NoWhitelist to NoPermission

Review of attachment 8381211 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/browser-element/mochitest/test_browserElement_NoPermission.html
@@ +13,5 @@
> +<a target="_blank" href="https://bugzilla.mozilla.org/show_bug.cgi?id=710231">Mozilla Bug 710231</a>
> +
> +<!--
> +  Test that an iframe with the |mozbrowser| attribute does not emit
> +  mozbrowserX events when this page is not in the whitelist.

nit: maybe adapt this comment too.
Attachment #8381211 - Flags: review?(fabrice) → review+
Attachment #8381212 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/mozilla-central/rev/329f4bf1b18a
https://hg.mozilla.org/mozilla-central/rev/c1b96bf3cf1d
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.