Closed Bug 970302 Opened 6 years ago Closed 6 years ago

'mach xpcshell-test' results in AttributeError: 'unicode' object has no attribute 'test_paths'

Categories

(Testing :: XPCShell Harness, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla30

People

(Reporter: past, Assigned: gps)

References

Details

(Keywords: regression)

Attachments

(1 file)

Started getting this today on fx-team tip (Ubuntu 13.10):

past@holo:fx-team$ ./mach xpcshell-test
From _tests: Kept 12805 existing; Added/updated 0; Removed 0 files and 0 directories.
Error running mach:

    ['xpcshell-test']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'unicode' object has no attribute 'test_paths'

  File "/home/past/src/fx-team/testing/xpcshell/mach_commands.py", line 333, in run_xpcshell_test
    return xpcshell.run_test(**params)
  File "/home/past/src/fx-team/testing/xpcshell/mach_commands.py", line 74, in run_test
    rerun_failures=rerun_failures)
  File "/home/past/src/fx-team/testing/xpcshell/mach_commands.py", line 52, in run_suite
    return self._run_xpcshell_harness(manifest=manifest, **kwargs)
  File "/home/past/src/fx-team/testing/xpcshell/mach_commands.py", line 124, in _run_xpcshell_harness
    verbose_output = test_path is not None or (manifest and len(manifest.test_paths())==1)
Why is "manifest" a unicode? That's really weird.
Component: mach → XPCShell Harness
Product: Core → Testing
        manifest = os.path.join(self.topobjdir, '_tests', 'xpcshell',
            'xpcshell.ini')

        return self._run_xpcshell_harness(manifest=manifest, **kwargs)
Assignee: nobody → gps
Status: NEW → ASSIGNED
Duplicate of this bug: 971562
Keywords: regression
Attachment #8373603 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/881a08901c0d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.