Closed Bug 970312 Opened 8 years ago Closed 8 years ago

Cannot set add-on type to "Any" from Admin Settings

Categories

(addons.mozilla.org Graveyard :: Developer Pages, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2014-02-11

People

(Reporter: vcarciu, Assigned: ahalliga)

References

()

Details

Steps to reproduce:
1.Go to https://addons-dev.allizom.org/en-US/developers/addon/slurac/edit
2.From Admin Settings set the add-on type to "Any"

Expected results:
The change is successfully saved

Actual results:
The waiting spinning wheel is continuously displayed and the change is not saved

I can see the following errors in my console:
Use of attributes' specified attribute is deprecated. It always returns true. common-min.js:1
POST https://addons-dev.allizom.org/en-US/developers/addon/slurac/admin [HTTP/1.1 500 INTERNAL SERVER ERROR 723ms]
'Any' isn't really a valid add-on type. That may be the reason behind the bug. It shouldn't appear in the dropdown, though, so there's still a bug here.
Fixed in https://github.com/mozilla/zamboni/commit/3ed85528d43bca9f6cccfc963f98311d733911f3
Assignee: nobody → ahalliga
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: 2014-02-04 → 2014-02-11
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.