stylesheets linked with titles are loaded as alt stylesheet

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
17 years ago
8 years ago

People

(Reporter: basic, Assigned: dbaron)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
given a HTML page with

<link rel="stylesheet" title="stylesheet 1" href="style1.css">
<link rel="stylesheet" title="stylesheet 2" href="style2.css">
<link rel="stylesheet" title="stylesheet 3" href="style3.css">

mozilla (build 2001082008) gives "stylesheet 2" and "stylesheet 3" as alternate
stylesheets!! I'll make a testcase. Note that the correct way to do alternate
stylesheets:
<link rel="stylesheet" title="stylesheet 1" href="style1.css">
<link rel="alternate stylesheet" title="stylesheet 2" href="style2.css">
<link rel="stylesheet alternate" title="stylesheet 3" href="style3.css">
does not work in mozilla.
(Reporter)

Comment 1

17 years ago
Created attachment 47155 [details]
stylesheet 1
(Reporter)

Comment 2

17 years ago
Created attachment 47156 [details]
stylesheet 2
(Reporter)

Comment 3

17 years ago
Created attachment 47157 [details]
stylesheet 3
(Reporter)

Comment 4

17 years ago
Created attachment 47158 [details]
testcase
(Reporter)

Comment 5

17 years ago
In testcase attachment 47158 [details] mozilla should be displaying the text "stylesheet
3" in blue and monospace font.
(Reporter)

Comment 6

17 years ago
I forgot to mention that what actually happens is that "stylesheet 1" is
displayed and in the View->Use Stylesheet menu I see none,"stylesheet 1",
"stylesheet 2" and "stylesheet 3".
(Assignee)

Comment 7

17 years ago
Created attachment 47159 [details]
testcase showing "stylesheet alternate" and "alternate stylesheet" work fine
(Assignee)

Comment 8

17 years ago
Our behavior is correct.  See
http://www.w3.org/TR/html4/present/styles.html#h-14.3 .

In particular, see the following two statements in 14.3.2:

"          * To make a style sheet persistent, set the rel attribute to
"stylesheet" and don't set the title attribute.
          * To make a style sheet preferred, set the rel attribute to
"stylesheet" and name the style sheet with the title attribute.
          * To specify an alternate style sheet, set the rel attribute to
"alternate stylesheet" and name the style sheet with the title attribute."

"If two or more LINK elements specify a preferred style sheet, the first one
takes precedence."

Marking bug as INVALID.  See the tests at
http://www.bath.ac.uk/~py8ieh/internet/importtest/ for testcases.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 9

17 years ago
verified
Status: RESOLVED → VERIFIED
*** Bug 104538 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

10 years ago
Duplicate of this bug: 436261
(Assignee)

Updated

8 years ago
Duplicate of this bug: 534505
You need to log in before you can comment on or make changes to this bug.