SDK buttons still look broken inside the menu

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Theme
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 30
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P2])

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
4.12 +/* Help SDK buttons fit in. */
    4.13 +toolbarpaletteitem[place="palette"] > #personal-bookmarks > #bookmarks-toolbar-placeholder,
    4.14 +#personal-bookmarks[cui-areatype="menu-panel"] > #bookmarks-toolbar-placeholder {
    4.15 +  height: 32px;
    4.16 +  width: 32px;
    4.17 +}
    4.18 +

Uhm. Not what I meant, I'm sure. Maybe I forgot to save the file? Either way, this should have applied to SDK buttons inside the menu. Clearly it doesn't. Instead, it makes the bookmarks toolbar items look like crap when they're in the menu
(Assignee)

Comment 1

4 years ago
Created attachment 8373671 [details] [diff] [review]
fix width and height of Australis SDK buttons in panel,

This being what I intended that hunk to be.
Attachment #8373671 - Flags: review?(jaws)
Comment on attachment 8373671 [details] [diff] [review]
fix width and height of Australis SDK buttons in panel,

Review of attachment 8373671 [details] [diff] [review]:
-----------------------------------------------------------------

And I feel equally bad for not noticing that on the previous review.
Attachment #8373671 - Flags: review?(jaws) → review+
(Assignee)

Comment 3

4 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/643c706bc2ef
Status: NEW → ASSIGNED
Whiteboard: [Australis:P2] → [Australis:P2][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/643c706bc2ef
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][fixed-in-fx-team] → [Australis:P2]
Target Milestone: --- → Firefox 30
(Assignee)

Comment 5

4 years ago
Comment on attachment 8373671 [details] [diff] [review]
fix width and height of Australis SDK buttons in panel,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 967115
User impact if declined: bookmarks toolbar items looks bad in panel, sdk buttons look bad in panel
Testing completed (on m-c, etc.): m-c, locally
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8373671 - Flags: approval-mozilla-aurora?
Attachment #8373671 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/0ff4ef608a5e
status-firefox29: --- → fixed
status-firefox30: --- → fixed
(Assignee)

Updated

4 years ago
Blocks: 961613

Updated

4 years ago
QA Contact: cornel.ionce

Comment 8

4 years ago
Reproduced on the 02/10 Nightly with the Bookmarks Toolbar item. Verified as fixed on Firefox 29.0b3 and the latest 30.0a2. All the testing was performed on Mac OS X 10.9.

What SDK buttons did you reproduce this with? I'd like to also verify that case before marking the bug as verified.
Flags: needinfo?(gijskruitbosch+bugs)

Updated

4 years ago
QA Contact: cornel.ionce → ioana.budnar
(Assignee)

Comment 9

4 years ago
(In reply to Ioana Budnar, QA [:ioana] from comment #8)
> Reproduced on the 02/10 Nightly with the Bookmarks Toolbar item. Verified as
> fixed on Firefox 29.0b3 and the latest 30.0a2. All the testing was performed
> on Mac OS X 10.9.
> 
> What SDK buttons did you reproduce this with? I'd like to also verify that
> case before marking the bug as verified.

To be honest, I'm really not sure anymore. It was 2 months ago. However, I think Lightbeam [0] would be a workable testcase?

[0] http://www.mozilla.org/en-US/lightbeam/
Flags: needinfo?(gijskruitbosch+bugs)

Comment 10

4 years ago
(In reply to :Gijs Kruitbosch from comment #9)
> To be honest, I'm really not sure anymore. It was 2 months ago. However, I
> think Lightbeam [0] would be a workable testcase?
> 
> [0] http://www.mozilla.org/en-US/lightbeam/

Unfortunately, the Lightbeam button doesn't reproduce this bug. Addblock, Stylish and NoScript don't reproduce it for me either.
(Assignee)

Comment 11

4 years ago
(In reply to Ioana Budnar, QA [:ioana] from comment #10)
> (In reply to :Gijs Kruitbosch from comment #9)
> > To be honest, I'm really not sure anymore. It was 2 months ago. However, I
> > think Lightbeam [0] would be a workable testcase?
> > 
> > [0] http://www.mozilla.org/en-US/lightbeam/
> 
> Unfortunately, the Lightbeam button doesn't reproduce this bug. Addblock,
> Stylish and NoScript don't reproduce it for me either.

I'm confused. The bug is fixed, so surely it's expected that it doesn't reproduce the issue? None of the other add-ons you list use SDK buttons, so they wouldn't be expected to run into this problem.

Comment 12

4 years ago
(In reply to :Gijs Kruitbosch from comment #11)
> I'm confused. The bug is fixed, so surely it's expected that it doesn't
> reproduce the issue? None of the other add-ons you list use SDK buttons, so
> they wouldn't be expected to run into this problem.

Before verifying a bug fix, QA tries to reproduce it on a buggy build for a more reliable verification. I don't reproduce this issue with Lightbeam on the 02/10 Nightly.

It doesn't reproduce on the latest Beta either, but since I can't reproduce it on the buggy Nightly, I can't know for sure whether the bug was fixed or it's just not reproducible on my environment.
Created attachment 8407442 [details]
broken_button_in_menu_panel.png

There still is an issue with the Stylish add-on into the menu panel.

Reproduced on Fx 29 beta 8 (build ID: 20140414143035), latest Aurora (build ID: 20140415004003) and latest Nightly (build ID: 20140415030203).

This is reproducing on Windows 7 64bit, Mac OS X 10.9, Ubuntu 12.04 32bit and Windows 8.1 64bit (MS Pro 2 - hiDPI).

Should we reopen this issue or file a separate bug for the mentioned behaviour?
Flags: needinfo?(gijskruitbosch+bugs)
(Assignee)

Comment 14

4 years ago
(In reply to Cornel Ionce [QA] from comment #13)
> Created attachment 8407442 [details]
> broken_button_in_menu_panel.png
> 
> There still is an issue with the Stylish add-on into the menu panel.
> 
> Reproduced on Fx 29 beta 8 (build ID: 20140414143035), latest Aurora (build
> ID: 20140415004003) and latest Nightly (build ID: 20140415030203).
> 
> This is reproducing on Windows 7 64bit, Mac OS X 10.9, Ubuntu 12.04 32bit
> and Windows 8.1 64bit (MS Pro 2 - hiDPI).
> 
> Should we reopen this issue or file a separate bug for the mentioned
> behaviour?

Stylish isn't using an SDK button, so it has no relation to this bug. This particular issue was tracked in bug 993208, and the author has released a fix, so neither a new bug nor reopening this one seem useful.
Flags: needinfo?(gijskruitbosch+bugs)
Marking this issue verified since I could not reproduce it using other add-ons.
Thank you!
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.