Calling getContext on a non-visible canvas used as a background crashes FF

RESOLVED WORKSFORME

Status

()

Core
Canvas: 2D
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: tobytailor, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Firefox Nightly crashes when trying to call getContext('2d') on a canvas that is non-visible (display:none) and is used as a background for another element (background:-moz-element(...)).

Code to reproduce: https://gist.github.com/anonymous/8922683
Created attachment 8459142 [details]
Test

I could not reproduce on Linux with this test case. Reporter, could you check if it does for you?
Flags: needinfo?(schneider)
(Reporter)

Comment 2

3 years ago
Can't reproduce it anymore either in latest Nightly.
Flags: needinfo?(schneider)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.