Closed Bug 970897 Opened 6 years ago Closed 6 years ago

The History panel is too small

Categories

(Firefox :: Toolbars and Customization, defect)

All
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- verified

People

(Reporter: ge3k0s, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3][good first verify] [testday-20140523])

Attachments

(1 file)

When the history widget is put in the toolbar the panel is very small and a scrollbar immediately appears. The panel should take more space on the screen before it shrinks and before a scrollbar appears.
Whiteboard: [Australis:P3]
Backing out bug 966905 fixes this. Sigh.

Jared, want to have a look at what's going on here?

Guillaume, does this happen when it's in the menu? It doesn't for me, but I just want to doublecheck I'm not missing anything. Thanks!
Blocks: 966905
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jaws)
Flags: needinfo?(ge3k0s)
(In reply to :Gijs Kruitbosch from comment #1)
> Guillaume, does this happen when it's in the menu? It doesn't for me, but I
> just want to doublecheck I'm not missing anything. Thanks!

No it doesn't happen as a subview. ;-)
Flags: needinfo?(ge3k0s)
I can't reproduce this. It was something that I noticed while working on bug 966905, but I was pretty sure I addressed it.

Possibly moving the -moz-box-flex:1 property from `.panel-subview-body` to `#PanelUI-popup .panel-subview-body` will fix it.
Flags: needinfo?(jaws)
This fixes things for me.
Attachment #8374182 - Flags: review?(jaws)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8374182 [details] [diff] [review]
use subview inner scroll height for Australis standalone panels,

Review of attachment 8374182 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/customizableui/content/panelUI.js
@@ +302,5 @@
>                                   viewNode.querySelector(".panel-subview-footer"));
>  
>        let multiView = document.createElement("panelmultiview");
>        tempPanel.appendChild(multiView);
> +      multiView.setAttribute("mainviewissubview", "true");

such a hard string to read when joined without spaces :(

it may be against convention, but can this use camelCase or something that has more ascenders/descenders?
Attachment #8374182 - Flags: review?(jaws) → review+
switched to camel case:

remote:   https://hg.mozilla.org/integration/fx-team/rev/b301202a5eb7
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/b301202a5eb7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
The panel isn't too small anymore but the scrollbar is always present which is still a bug.
(In reply to Guillaume C. [:ge3k0s] from comment #8)
> The panel isn't too small anymore but the scrollbar is always present which
> is still a bug.

Please file a separate bug with steps to reproduce.
Comment on attachment 8374182 [details] [diff] [review]
use subview inner scroll height for Australis standalone panels,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression from bug 966905
User impact if declined: subviews when used as panels in the toolbar will have incorrect height
Testing completed (on m-c, etc.): on m-c for a day now
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none

note: needs to land on top of the patch for bug 966905.
Attachment #8374182 - Flags: approval-mozilla-aurora?
Attachment #8374182 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 972359
Whiteboard: [Australis:P3] → [Australis:P3][good first verify]
Verified fixed using Windows 7 64 bit and Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0. Verified in latest Nightly as well, setting the STATUS to VERIFIED.
Status: RESOLVED → VERIFIED
Whiteboard: [Australis:P3][good first verify] → [Australis:P3][good first verify] [testday-20140523]
I can also confirm this as verified fixed with latest Fx 30 beta 7 (Build ID: 20140522105902) on Windows 7, both 64bit and 32bit.
You need to log in before you can comment on or make changes to this bug.