Closed Bug 970965 Opened 7 years ago Closed 7 years ago

[Session Restore] Twitter tab are restored to the one state before the actual state

Categories

(Firefox :: Session Restore, defect)

29 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 967028
Tracking Status
firefox28 --- unaffected
firefox29 - affected
firefox30 - affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: regression)

Steps To Reproduce:
1. Open https://twitter.com and Sign-in and remember
2. Go https://twitter.com/i/connect in the same tab
3. Click "Home" at the left-upper of a page
   --- observe, URL is https://twitter.com now
4. Exit Browser
5. Start Firefox again
6. Click "Restore Previous Session"
   ---  observe URL

Actual Results:
Restored tab to the one state before.
I.E. URL is https://twitter.com/i/connect

Expected Results:
Restored tab to the last one.
URL should be https://twitter.com

Regression window(fx)
Good:
http://hg.mozilla.org/integration/fx-team/rev/0a2824f4e03b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140124085803
Bad:
http://hg.mozilla.org/integration/fx-team/rev/c7c63c6c2433
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140124091931
Pushlog:
http://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=0a2824f4e03b&tochange=c7c63c6c2433

Regressed by: Bug 960903
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967028
Already tracking the duplicate
You need to log in before you can comment on or make changes to this bug.