Closed Bug 970973 Opened 6 years ago Closed 5 years ago

Empty space in toolbar where lock icon would go

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox28 --- unaffected
firefox29 --- wontfix
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: Margaret, Assigned: mcomella)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image screenshot
I ran into this last night, and the empty space stayed there even as I switched tabs and navigated to other pages.

I can't reproduce right now, but I'll pay attention to see if I run into this again. At the time, I was opening links from Twitter, so maybe something with loading external URLs triggered this?
tracking-fennec: --- → ?
There was a similar issue logged a while ago in bug 867608 and bug 873086. I'll look into this and see if I can reproduce.
Mihai, any luck reproducing this bug?
Flags: needinfo?(mihai.g.pop)
Tried on several devices, and different scenarios but no luck reproducing this issue.
Flags: needinfo?(mihai.g.pop)
I was the one who originally filed this bug, and I haven't seen this again, so I'm closing as WORKSFORME. I can reopen if I see it happen again.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
tracking-fennec: ? → 30+
Attached image Empty_Space_Beta.png
Device: LG Nexus 4 (Android 4.4.2)
Build: Firefox for Android 29 Beta 2 (2014-03-25)

I ran into this, but I don't have steps to reproduce.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
tracking-fennec: 30+ → +
Still reproducing on latest Nightly 31.0a1(2014-04-09), unfortunately haven't got the steps to reproduce
Duplicate of this bug: 995339
STR from bnicholson in bug 994339: Do a search and create a new tab before the lock icon appears. See screenshot.
Can reproduce in beta, but not release.
tracking-fennec: + → ?
Keywords: steps-wantedregression
Assignee: nobody → michael.l.comella
Status: REOPENED → ASSIGNED
It seems the issue was the favicon animation would start, but when disabling animations while switching tabs, we only changed the security visibility, rather than cancelling the animation, which sets the page title position, thus the position was never reset, and the gap was shown.
Attachment #8406343 - Flags: review?(lucasr.at.mozilla)
Comment on attachment 8406343 [details] [diff] [review]
Prevent empty space in security identity.

Review of attachment 8406343 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch.
Attachment #8406343 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/e2b517f57867
Status: ASSIGNED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Verified as fixed on Nightly 31.0a1(2014-04-16) using the STR from bnicholson. Will this be uplifted to aurora and beta?
(In reply to Mihai Pop from comment #14)
> Verified as fixed on Nightly 31.0a1(2014-04-16) using the STR from
> bnicholson. Will this be uplifted to aurora and beta?

While it seems fairly harmless to uplift to Beta, I don't think we have enough time to let it comfortably ride the trains. It doesn't appear to be a significant issue (I don't think I've ever repro'd in the wild) so I think uplifting to just Aurora would be fine. Thank you for the reminder.
Comment on attachment 8406343 [details] [diff] [review]
Prevent empty space in security identity.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Unknown.

User impact if declined:
  While quickly changing tabs, users may see an empty space in the toolbar. As far as I know, this should only happen on non-secure sites, meaning there is no loss in functionality (besides a few missing page title characters) - it just looks unpolished. See the attached screenshots.

Testing completed (on m-c, etc.):
  Local testing.
 
Risk to taking this patch (and alternatives if risky):
  Low - this patch performs animation cancellation everytime this lock icon should be set visible or invisible, as opposed to only when a particular flag is not set, so worst comes to worst, some UI mechanic screws up in another edge case and it looks less polished.

String or IDL/UUID changes made by this patch: N/A
Attachment #8406343 - Flags: approval-mozilla-aurora?
Comment on attachment 8406343 [details] [diff] [review]
Prevent empty space in security identity.

Correct - we are out of time for Beta.
Attachment #8406343 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
tracking-fennec: ? → 30+
Verified as fixed on Aurora 30.0a2(2014-04-18) on Alcatel One Touch (Android 4.1.2).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.