Closed Bug 970990 Opened 6 years ago Closed 6 years ago

Remove the watermark image because background-attachment: fixed doesn't work with apzc

Categories

(Firefox for Metro Graveyard :: Theme, defect, P1)

x86_64
Windows 8.1
defect

Tracking

(firefox28+ fixed, firefox29+ fixed, firefox30+ fixed, b2g-v1.3 fixed)

VERIFIED FIXED
Firefox 30
Tracking Status
firefox28 + fixed
firefox29 + fixed
firefox30 + fixed
b2g-v1.3 --- fixed

People

(Reporter: jimm, Assigned: jimm)

References

Details

(Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 [qa-])

Attachments

(1 file, 2 obsolete files)

We can't use this feature due to the following bugs:

bug 970942 - fixed background images on sub document elements jitter and jump during async touch panning/scrolling
bug 969354 - black rect to left of the about:start watermark displays when scrolling

related:

bug 946502 -  background-attachment: fixed images jitter and jump during async touch panning/scrolling
Attached patch fix (obsolete) — Splinter Review
Attachment #8374125 - Flags: review?(mbrubeck)
Comment on attachment 8374125 [details] [diff] [review]
fix

oops, that's going to take the background color with it.
Attachment #8374125 - Flags: review?(mbrubeck)
Attached patch fix (obsolete) — Splinter Review
Attachment #8374125 - Attachment is obsolete: true
Attachment #8374127 - Flags: review?(mbrubeck)
Attachment #8374127 - Flags: review?(mbrubeck) → review+
Assignee: nobody → jmathies
Status: NEW → ASSIGNED
QA Contact: jbecerra
Whiteboard: [release28] → [release28] p=0 s=it-30c-29a-28b.1 r=ff28
Hey Jim, I need a point value for this bug.
Flags: needinfo?(jmathies)
Attached patch exportSplinter Review
Attachment #8374127 - Attachment is obsolete: true
Attachment #8374179 - Flags: review+
Flags: needinfo?(jmathies)
Duplicate of this bug: 946664
Whiteboard: [release28] p=0 s=it-30c-29a-28b.1 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28
https://hg.mozilla.org/integration/fx-team/rev/241bc554c85b
Keywords: checkin-needed
Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28[fixed-in-fx-team]
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/241bc554c85b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28[fixed-in-fx-team] → [release28] p=1 s=it-30c-29a-28b.1 r=ff28
Target Milestone: --- → Firefox 30
Comment on attachment 8374179 [details] [diff] [review]
export

Removing a background image on the start screen that had some rendering problems.
Attachment #8374179 - Flags: approval-mozilla-beta?
Attachment #8374179 - Flags: approval-mozilla-aurora?
Attachment #8374179 - Flags: approval-mozilla-beta?
Attachment #8374179 - Flags: approval-mozilla-beta+
Attachment #8374179 - Flags: approval-mozilla-aurora?
Attachment #8374179 - Flags: approval-mozilla-aurora+
Whiteboard: [release28] p=1 s=it-30c-29a-28b.1 r=ff28 → [release28] p=1 s=it-30c-29a-28b.1 r=ff28 [qa-]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.