RESOLVED FIXED

Status

Release Engineering
Releases
RESOLVED FIXED
4 years ago
a year ago

People

(Reporter: Anton Derbenev, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1835.0 Safari/537.36

Steps to reproduce:

wget -N -np -r releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/win32/ru/


Actual results:

it gave me Thunderbird Setup 24.2.0.exe


Expected results:

it should have give me Thunderbird Setup 24.3.0.exe, which is available at releases.mozilla.org/pub/mozilla.org/thunderbird/releases/24.3.0/win32/ru/

Updated

4 years ago
Component: Web Site → Releases
Product: Mozilla Services → Release Engineering
QA Contact: rail
Assignee: nobody → rail
Good catch. Thanks! Looks like we forgot to update the symlink for the last release...

It should be fixed now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
Hi. That happened again.

Maybe some daily script can fix that? One which finds latest dir without "-rc$" and "b[0-9]*$" in pub/mozilla.org/thunderbird/releases/ and links it.

Or maybe same which generates url for https://www.mozilla.org/en-US/thunderbird/
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Comment 3

3 years ago
a bit more specifically: current release is pub/mozilla.org/thunderbird/releases/31.1.0/, but http://download.cdn.mozilla.net/pub/mozilla.org/thunderbird/releases/ points to pub/mozilla.org/thunderbird/releases/31.0/
Ooops, someone forgot to run the postrelease task. On it.
This should be fixed now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
Hi. I rarely use Firefox nowadays, but on many workstation it's automagically (unattendedly) updated by downloading and installing latest version from mozilla.mirrors.tds.net/pub/mozilla.org/firefox/releases/latest/win32/ru/

I just noticed, this link isn't actual also. It still points to 31.0. And, when I try to open http://mozilla.mirrors.tds.net/pub/mozilla.org/firefox/releases/32.0/, it shows me nagscreen that 32.0 isn't released yet (which is plain wrong).


Maybe there is there another way to unattendedly download & install latest MT & FF?
Sounds like an outdated mirror:

http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/
and
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/32.0.2/
look good to me.

BTW, how did you end up on that URL?
(Reporter)

Comment 8

3 years ago
@Rail Aliiev [:rail] ok, it's my mistake then.

Here's how I ended up that way: since update works on several (about 50-60) workstations, it can lead to significant load on "internal" FTP. And I've read somewhere that releases should be downloaded from releases.mozilla.org because of that.
But releases.mozilla.org redirected me to mirror, which confused wget's recursion (w/o -H). So I just wrote direct URL of that mirror. Btw, it was unchanged and working well from jan 2013 until 32.0 release.
(Reporter)

Comment 9

2 years ago
Hi.

This happened again.

Both http://download.cdn.mozilla.net/pub/mozilla.org/thunderbird/releases/latest/ and http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/latest/ point to 31.6.0, but my MT offered 31.7.0 today (and indeed, it's there: http://download.cdn.mozilla.net/pub/mozilla.org/thunderbird/releases/31.7.0/).
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
I fixed it manually. This will be repeated again until we release TB 38, because 31.x.x's new latest location is latest-31: http://download.cdn.mozilla.net/pub/mozilla.org/thunderbird/releases/latest-31/

Additionally, there will be some changes to FTP this year, see https://ftangftang.wordpress.com/2015/04/21/changes-coming-to-ftp-mozilla-org/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

a year ago
Hi all again.

Since may, I've been using https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=ru to get latest Thunderbird, and it's been working for around a year.
But release 45 is not downloading via that link :( Instead I'm getting 38.7.2.

>wget --spider "https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=ru"
Spider mode enabled. Check if remote file exists.
--2016-04-22 09:14:48--  https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=ru
Connecting to 192.168.127.1:3128... connected.
WARNING: cannot verify download.mozilla.org's certificate, issued by `/C=US/O=DigiCert Inc/CN=DigiCert Secure Server CA':
  Unable to locally verify the issuer's authority.
Proxy request sent, awaiting response... 302 Found
Location: http://download.cdn.mozilla.net/pub/thunderbird/releases/38.7.2/win32/ru/Thunderbird%20Setup%2038.7.2.exe [following]
Spider mode enabled. Check if remote file exists.
--2016-04-22 09:14:50--  http://download.cdn.mozilla.net/pub/thunderbird/releases/38.7.2/win32/ru/Thunderbird%20Setup%2038.7.2.exe
Connecting to 192.168.127.1:3128... connected.
Proxy request sent, awaiting response... 200 OK
Length: 34412184 (33M) [application/x-msdownload]
Remote file exists.
(Reporter)

Updated

a year ago
Summary: outdated link: releases.mozilla.org/pub/mozilla.org/thunderbird/releases/latest → outdated link: https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=ru
(Reporter)

Updated

a year ago
Summary: outdated link: https://download.mozilla.org/?product=thunderbird-latest&os=win&lang=ru → outdated link: https://download.mozilla.org/?product=thunderbird-latest
(Reporter)

Comment 12

a year ago
no proxy for wget, no lang and no platform in URL. Same results:

>wget --spider https://download.mozilla.org/?product=thunderbird-latest
Spider mode enabled. Check if remote file exists.
--2016-04-22 09:36:40--  https://download.mozilla.org/?product=thunderbird-latest
Resolving download.mozilla.org... 54.209.214.10
Connecting to download.mozilla.org|54.209.214.10|:443... connected.
WARNING: cannot verify download.mozilla.org's certificate, issued by `/C=US/O=DigiCert Inc/CN=DigiCert Secure Server CA':
  Unable to locally verify the issuer's authority.
HTTP request sent, awaiting response... 302 Found
Location: http://download.cdn.mozilla.net/pub/thunderbird/releases/38.7.2/win32/en-US/Thunderbird%20Setup%2038.7.2.exe [following]
Spider mode enabled. Check if remote file exists.
--2016-04-22 09:36:41--  http://download.cdn.mozilla.net/pub/thunderbird/releases/38.7.2/win32/en-US/Thunderbird%20Setup%2038.7.2.exe
Resolving download.cdn.mozilla.net... 37.29.19.90, 37.29.19.83
Connecting to download.cdn.mozilla.net|37.29.19.90|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 34123832 (33M) [application/x-msdownload]
Remote file exists.
this is bug 1265936
You need to log in before you can comment on or make changes to this bug.