Closed Bug 971086 Opened 7 years ago Closed 7 years ago

[Camera] 1.4 Visual Design - Image Capture/ Video Buttons

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S5 (11apr)
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: amylee, Assigned: dmarcos)

References

Details

(Whiteboard: ux-tracking, visual design, jian [fxos:media])

Attachments

(5 files, 7 obsolete files)

Redesign of image capture/video record buttons

Will attach visual specs
Assignee: nobody → wilsonpage
I took this bug yesterday and already start to work on it

https://bugzilla.mozilla.org/show_bug.cgi?id=971510

Is it ok for you if I take this as well?
Flags: needinfo?(wilsonpage)
dmarcos: I thought you were working on the build time configuration for the new settings architecture (bug 965486). Lack of this feature is a serious blocker for v1.4 as it means partners cannot configure the camera app is the current way.

This bug aligns well with my skill-set, plus I've already implemented the proof of concept in my 'controls-refresh' branch, which I've begun porting across.

bug 971510 isn't a blocker for v1.4 as Mozilla camera may not have a visible settings menu.

We don't have much dev time left in v1.4, especially with the upcoming work week, I'm concerned we won't have ticked off our blockers :-/
Flags: needinfo?(wilsonpage)
Duplicate of this bug: 973674
Assignee: wilsonpage → dmarcos
Attached file PR - Work in progress (obsolete) —
Attachment #8378420 - Flags: feedback?(wilsonpage)
Comment on attachment 8378420 [details] [review]
PR - Work in progress

r+ under the condition raised comments (Github) are addressed :)
Attachment #8378420 - Flags: feedback?(wilsonpage) → feedback+
Single shutter - camera toggle spec
Attached image video_toggle_icon.svg (obsolete) —
Video toggle icon
Attached image camera_toggle_icon.svg (obsolete) —
camera toggle icon
Attached image video_toggle_icon.svg (obsolete) —
Attachment #8379204 - Attachment is obsolete: true
Attached image camera_toggle_icon.svg (obsolete) —
Attachment #8379205 - Attachment is obsolete: true
Spec for single shutter video toggle
Single shutter camera toggle
Attachment #8379195 - Attachment is obsolete: true
Attached image video_stop_recording.svg (obsolete) —
Video stop recording icon
Attached file Pull Request
Attachment #8378420 - Attachment is obsolete: true
Target Milestone: --- → 1.4 S3 (14mar)
Hi Diego, 

Can you check the single shutter spec for the correct image grid button? Icon should be 3x3 rems and a semi-transparent 54x54px circle behind it. Also the image capture button looks off centered. Can you look through the spec to check the spacing of the controls? 

Thanks!
Flags: needinfo?(dmarcos)
It's not finalized. We'll be requesting ui review when those patches are final.
Attachment #8385832 - Flags: review?(dflanagan)
I've started reviewing this and have preliminary comments on github, but not done.
I don't see any of the attached images in the pull request. Are they already in the icon font perhaps?
Amy,

The svg images you have attached are all > 100kb because they contain an encoded binary raster version of the image in addition to this nice clean svg image.

This has been a problem on other bugs as well. Do you have a way to export your svg so that it is small and clean?
Flags: needinfo?(amlee)
Attached file SVG_Icons.zip
Hi David, 

I've re-exported the icons and got them down to around 1KB. Let me know if these work for you and I'll do the same for the rest of the camera app icons.
Attachment #8379210 - Attachment is obsolete: true
Attachment #8379211 - Attachment is obsolete: true
Attachment #8379253 - Attachment is obsolete: true
Flags: needinfo?(amlee)
Comment on attachment 8385832 [details] [review]
pull-request (camera-new-features)

r- mainly for issues related to the thumbnail: you need to base it on the EXIF preview so you don't decode the full-size image.  Also, you don't create a video thumbnails.

I've left a lot of other comments on the commit as well.
Attachment #8385832 - Flags: review?(dflanagan) → review-
Attachment #8385832 - Flags: review- → review?(dflanagan)
Flags: needinfo?(dmarcos)
Comment on attachment 8385832 [details] [review]
pull-request (camera-new-features)

I have not had time to run the code, so I don't know what the new controls look like, but the code looks great.  I've commented on a few nits on github, but they are minor.

Please be aware of the patch in 949941. That should land to master soon, and may cause minor merge conflicts with this patch.
Attachment #8385832 - Flags: review?(dflanagan) → review+
Blocks: 971090
Landed on camera-new-features:

https://github.com/mozilla-b2g/gaia/commit/ce8e2cc83b6db75e6cd30d556905815a4a90baa9
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Bulk edit for camera bugs.

If earlier comments do not show how this bug landed to master, it probably landed as part of https://github.com/mozilla-b2g/gaia/pull/17599 which merged the camera-new-features branch into master.

This bug was uplifted from master to v1.4 as part of https://github.com/mozilla-b2g/gaia/commit/a8190d08e61316a86bba572ba8d894d081a20530
Target Milestone: 1.4 S3 (14mar) → 1.4 S5 (11apr)
The bug is no longer reproduces on 1.4 and 1.5 master builds.
Visual design is redesigned for Image Capture/Video buttons

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140410000201
Gaia: 9b2da43dfee3792cd311ae55f0b06272313208f0
Gecko: 9d9ead7d6afa
Version: 30.0a2
Firmware Version: v1.2-device.cfg

1.5 Environmental Variables:
Device: Buri 1.5 MOZ
BuildID: 20140410040201
Gaia: 9d0b1bdf746823a94b13e6574c1d8304dc584763
Gecko: 690c810c8e3e
Version: 31.0a1
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.