crash in java.lang.NoSuchMethodError: android.view.View.setBackground at org.mozilla.gecko.widget.BasicColorPicker$ColorPickerListAdapter.getView(BasicColorPicker.java)

RESOLVED FIXED in Firefox 30

Status

()

--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: lucasr)

Tracking

(Blocks: 1 bug, {crash})

30 Branch
Firefox 30
All
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-c20679bd-e261-41cc-a4e0-5c7b82140208.
=============================================================

java.lang.NoSuchMethodError: android.view.View.setBackground
	at org.mozilla.gecko.widget.BasicColorPicker$ColorPickerListAdapter.getView(BasicColorPicker.java:125)
	at android.widget.AbsListView.obtainView(AbsListView.java:1480)
	at android.widget.ListView.measureHeightOfChildren(ListView.java:1254)
	at android.widget.ListView.onMeasure(ListView.java:1165)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1058)
	at android.widget.LinearLayout.measureVertical(LinearLayout.java:425)
	at android.widget.LinearLayout.onMeasure(LinearLayout.java:345)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:281)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:281)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.LinearLayout.measureChildBeforeLayout(LinearLayout.java:1058)
	at android.widget.LinearLayout.measureVertical(LinearLayout.java:425)
	at android.widget.LinearLayout.onMeasure(LinearLayout.java:345)
	at com.android.internal.widget.WeightedLinearLayout.onMeasure(WeightedLinearLayout.java:91)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:281)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewGroup.measureChildWithMargins(ViewGroup.java:3169)
	at android.widget.FrameLayout.onMeasure(FrameLayout.java:281)
	at android.view.View.measure(View.java:8362)
	at android.view.ViewRoot.performTraversals(ViewRoot.java:880)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1913)
	at android.os.Handler.dispatchMessage(Handler.java:130)
	at android.os.Looper.loop(SourceFile:351)
	at android.app.ActivityThread.main(ActivityThread.java:3826)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:538)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:969)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:727)
	at dalvik.system.NativeStart.main(Native Method)
Reproduced on Android 2.2, HTC t-mobile G2. Looks like Gingerbread might also be affected.

As I suspected the crash happens as soon as you tap on the color picker widget.
Blocks: 875750
Whiteboard: [native-crash]
(Assignee)

Updated

5 years ago
Assignee: nobody → lucasr.at.mozilla
(Assignee)

Comment 2

5 years ago
Created attachment 8383223 [details] [diff] [review]
Use setBackgroundDrawable() in BasicColorPicker (r=wesj)
(Assignee)

Comment 3

5 years ago
Comment on attachment 8383223 [details] [diff] [review]
Use setBackgroundDrawable() in BasicColorPicker (r=wesj)

Top crasher in Fx30. setBackground() is only available on Android >= 16.
Attachment #8383223 - Flags: review?(wjohnston)
Attachment #8383223 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/7c28d2a6b738
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
You need to log in before you can comment on or make changes to this bug.