X Closing pop-up crashes Mozilla with KERNEL32.DLL error

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Tim Johnson, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Windows ME
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.3+) Gecko/20010826
BuildID:    2001082608

From the www.alltel.com home, choosing site map, then wireless, there is a
pop-up requesting the zip code be supplied. This is in reponse to the referenced
URL. Entering the zip code and clicking OK does not seem to do anything (This
itself may be a Mozilla problem since it seems to work OK for Netscape 4.75).
However, upon clicking the pop-up's X in it's frame to close it, Mozilla crashes
with the error pop-up "Mozilla has caused an error in KERNEL32.DLL"

Reproducible: Always
Steps to Reproduce:
1.Either start from the referenced URL or (with www.alltel.com, then site map,
then Residential Services)
2.Click Wireless
3.Type zip code in the pop-up. I used 85747, but I don't think it matters, click
OK. Nothing appears to happen.
4. Click the pop-up X in frame to close. There is some flickering before the crash.

Actual Results:  Crash.

Expected Results:  Clicking the X should simply dismiss the pop-up.
Clicking OK should take one to the next  step in Alltel's process.

There may be two bugs here. 
1. No response to clicking OK after entering zip code in the pop-up.
2. Mozilla crash after clicking on pop-up's X in it's frame.

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 1

17 years ago
I can't reproduce the crash, but I can confirm that the OK button isn't working,
however this seems to be because of proprietary JS. Though I'm not sure (not
very familiar with the DOM) the following code doesn't look like it's cross browser:
    function submitData() {
        if( document.all )
            var zipcode = document.dataForm.zipcode.value;
        else
            var zipcode = document.dataLayer.document.dataForm.zipcode.value;
// removed rest
        }
This code is called by (<a href="#" onClick="javascript:submitData();return
false;"><img src="images/ok-button.gif" border="0"></a>) the OK button.
Using 2001082710 (cvs) on win2k.

Comment 2

17 years ago
yup, that is an evang issue (the OK button)
Someone has filed bug 97645 for the OK button/Evangelism issue.  Let's use this
bug for the reporter's intent: the crash.
Keywords: stackwanted
(Assignee)

Comment 4

17 years ago
If you are crashing in Mozilla the best thing you can do to help the developers
fix your bug is to attach a stacktrace. If you're not building yourself you are
not out of luck.  Mozilla (thanks to a very cool donation from Netscape)
releases nightly and milestone builds with Full Circle's Talkback. Talkback
should catch most crashes and offer to send in a crash report. I can retrieve
that crash report and attach it to your bug report if you provide either the
Incident ID (you can get it by running the talkback program from
/components/talkback/) or you can let me know the email address you used to
submit the report and the time of sending. Thanks for your help in testing
Mozilla and reporting bugs.
(Reporter)

Comment 5

17 years ago
Asa, thanks for your comments. I do pick up the nightlies at least once a week.

As to this bug, I've gone back to Alltel's site, but it seems they've changed
their pages somewhat. Now when I click on the Wireless link, nothing happens at
all. Mozilla recognizes it as a link because the cursor changes to a hand. But,
clicking on it results in no action. This occrus on their URL:
http://estore.alltel.com/Dispatch.jsp?.NewState=Enter.

The same is true using Netscape 6.1 except that the one link there which does
work for both Netscape and Mozilla (the one labeled "dsl service locator"), when
clicked from Netscape 6.1 causes the crash when that Browser window is
terminated. This does not happen on the 2001092308 Mozillia nightly.

The net is that it appears Mozilla no longer crashes as before. I don't know
what it is about those Alltel links that make them nonfunctional.
(Assignee)

Comment 6

17 years ago
Thanks for the followup. Can you please file a new bug on the new issue and I'll
resolve this one. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
Whatever it is about the nonfunctional links at the noted Alltel URL seems NOT
to be a Mozillz problem. They are nonfunctional with MSIE as well. I think the
problem is with Alltel.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.