Loading spinner loses alignment just as the page loads

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: cvan)

Tracking

Other
Android
Points:
---

Details

(Whiteboard: [cosmetic])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8374484 [details]
screencast

Android: 4.0.3
Firefox mobile: 30.0a1(2014-02-06)

steps to reproduce:
1. Load marketplace-dev.allizom.org on your firefox mobile nightly
2. Notice the loading screen screen particularly the spinner


observed behavior:
Just as the page loads, the spinner gets a little dancey and loses it's alignment. See attached video
Krupa did you touch the screen? That looks like that same bug from like a year ago.

Also, lol
(Reporter)

Comment 2

5 years ago
(In reply to Christopher Van Wiemeersch [:cvan] from comment #1)
> Krupa did you touch the screen? That looks like that same bug from like a
> year ago.
> 
> Also, lol

Nope, I didn't touch the screen.

Comment 3

5 years ago
Sounds like the fancy new css spinner cvan is working on will fix this.
Assignee: nobody → cvan
Priority: -- → P3
(Reporter)

Updated

5 years ago
Duplicate of this bug: 971879
(Reporter)

Updated

5 years ago
Duplicate of this bug: 978040
Fwiw: from the dupe bug 978040 - this was happening with the new shiny and the old version.
Did some testing locally, this "only" happens if there are enough apps to require scrolling once the page loads. You can fix it by putting an element that is tall enough on the page to force a scrollbar. It appears as though you cannot set the element's height in JS as the new throbber will bounce back-and-forth between the two positions.

Managed to fix it in CSS though after writing this... https://github.com/mozilla/fireplace/pull/399
This is fixed by cvan's updated updated spinner. https://github.com/mozilla/fireplace/commit/e985d25b815788e2f4a7b858d0b81d788670d9aa.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Whiteboard: [cosmetic]
You need to log in before you can comment on or make changes to this bug.