Firefox Beta release notes redirect to 404 page

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lsblakk, Assigned: pmac)

Tracking

Production
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: r=125058)

Attachments

(1 attachment, 1 obsolete attachment)

See https://support.mozilla.org/en-US/questions/986002 - it looks like in generating the final RC of 27, the notes link in the product is generated as a release version (losing the 'beta' in the url).
This comes from 
 http://hg.mozilla.org/build/tools/file/default/release/patcher-configs/mozBeta-branch-patcher2.cfg#l12

We didn't make any changes for the RC, perhaps we lost a redirect on www.mozilla.org ?
http://hg.mozilla.org/build/tools/rev/3b74f66321b1 shows that we have been using the same URL schema for previous betas as well... Sounds as a website issue to me too.
The url usually comes from
 http://hg.mozilla.org/build/tools/file/default/lib/perl/Release/Patcher/Config.pm#l11
Note that it uses the app version (ie 28.0) rather than our 28.0bN style of labeling releases.

So, rather than a lost redirect, it looks more like our web page location changed for beta notes but we didn't realize we had something to update. Fair ?
Flags: needinfo?(lsblakk)
(Reporter)

Updated

5 years ago
Component: Releases → Bedrock
Flags: needinfo?(lsblakk)
Product: Release Engineering → www.mozilla.org
QA Contact: rail
Version: other → Production
(Reporter)

Comment 4

5 years ago
You're right - I now realize that this is about the redirect that used to exist in our .htaccess file where we pointed http://www.mozilla.org/en-US/firefox/CURRENT_VERSION/releasenotes/ to http://www.mozilla.org/en-US/firefox/CURRENT_VERSIONbeta/releasenotes/  until the version was released. 

Pmac, I think this might be your area?
Flags: needinfo?(pmac)
Looks like maybe so. I'll see what I can find out and report back. It seems clear that we're in the right component now though. Thanks for the ping.
Assignee: nobody → pmac
Flags: needinfo?(pmac)
Created attachment 8381496 [details] [diff] [review]
bug-971351.patch

I believe this should fix it. It's a reversion of r123807. We'll need to deal with this again when releasenotes move to bedrock, which is happening soon! (yaaaay!)
Attachment #8381496 - Flags: review?(steven)
Comment on attachment 8381496 [details] [diff] [review]
bug-971351.patch

Review of attachment 8381496 [details] [diff] [review]:
-----------------------------------------------------------------

Discussed on IRC and this would likely re-break Bug 953131 (see r123802). pmac said he would update to be specific to 'releasenotes' only.
Attachment #8381496 - Flags: review?(steven) → review-
Created attachment 8381593 [details] [diff] [review]
bug-971351.patch

Updated patch to only catch ".../releasenotes/" urls.
Attachment #8381496 - Attachment is obsolete: true
Attachment #8381593 - Flags: review?(steven)
I've actually since added a '$' to the end of the match URL just to be sure we're only getting what we want, but haven't yet updated the patch. In practice I think these will be mostly identical.
Comment on attachment 8381593 [details] [diff] [review]
bug-971351.patch

Review of attachment 8381593 [details] [diff] [review]:
-----------------------------------------------------------------

It looks like this updated version assumes the URL will always end with the slash ("releasenotes/") - is that always the case?
Comment on attachment 8381593 [details] [diff] [review]
bug-971351.patch

Review of attachment 8381593 [details] [diff] [review]:
-----------------------------------------------------------------

Talked this through with pmac on IRC - the trailing slash would get added even if it wasn't included originally.
Attachment #8381593 - Flags: review?(steven) → review+
Applied in r125058.
Whiteboard: r=125058
Committed to prod in r125063.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.