If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Sora][Wi-Fi]DUT only support "EAP-SIM" for "EAP-WPA"

RESOLVED DUPLICATE of bug 922930

Status

Firefox OS
Wifi
P1
normal
RESOLVED DUPLICATE of bug 922930
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Mozilla build ID: 20140118004001
 DEFECT DESCRIPTION:
  DUT only support "EAP-SIM" for "EAP-WPA".
  REPRODUCING PROCEDURES:
  1,Home->Setting->enable Wi-Fi
  2,Searching the ap automatically -> connect the "WPA-EAP" AP ->Choose the EAP 
  method ->DUT only support "EAP-SIM" for "EAP-WPA".->KO
  EXPECTED BEHAVIOUR:
  DUT support TTLS,PEAP,SIM,AKA,TLS for "EAP-WPA".
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Other EAP mode are disabled until server certificate import is completed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922930
(Reporter)

Comment 2

4 years ago
What is the estimated time to complete?
1.4
(Reporter)

Comment 4

4 years ago
Bye the way, is "EAP-SIM" supported well on soul 3.5?
 
 (In reply to comment #3)
 > Comment from Mozilla:1.4
 >
We only support "set config" of EAP-SIM now, naming set network with "key_mgmt=WPA-EAP" and "eap=SIM".
The state machine and key auth is not implemented in gecko because there haven't be a common interface among vendors.
For now, these functionalities must be implemented in wpa_supplicant without gecko involved.

So it depends on the wpa_supplicant of the platform to determine if EAP-SIM is supported or not.
AFAIK, only fugu supports EAP-SIM because it satisfies such requirement.
You need to log in before you can comment on or make changes to this bug.