Closed Bug 971441 Opened 7 years ago Closed 7 years ago

[Camera][Madai] Visual Design Face Tracking Visual Indicator

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: amylee, Assigned: gjyothiprasad)

References

Details

(Whiteboard: ux-tracking, visual design, jian [fxos:media] [m+])

Attachments

(1 file)

User Story:

As a user, while in camera mode I want auto focus be set to face tracking if the device is capable of doing face tracking

Acceptance criteria:
1. When the user is in camera mode, the camera attempts face tracking if faces are detected
2. For each face detected there should be a visual indicator
3. Once a face is detected and focused, a single visual focus indicator is shown on the primary face and all other focus indicators should be removed
4. The color of the visual indicator should change indicating that face tracking has been successful

Will attach visual specs to bug
No longer blocks: 965489, 966764
Blocks: 971444
blocking-b2g: --- → madai?
Summary: [Camera][M] 1.4 Visual Design Face Tracking Visual Indicator → [Camera][Madai] 1.4 Visual Design Face Tracking Visual Indicator
Duplicate of this bug: 971211
Updated specs to CSS pixel measurements.
Prasad! 

Please attach the screenshot of current implementation to be reviewed by Mozilla UX.

And request Amy to review.
Assignee: nobody → gjyothiprasad
Tracking with madai flag
blocking-b2g: madai? → ---
Whiteboard: ux-tracking, visual design, jian [fxos:media] → ux-tracking, visual design, jian [fxos:media] [m+]
Face tracking is not in 1.4, adjusting dependency and summary.
No longer blocks: 971444
Summary: [Camera][Madai] 1.4 Visual Design Face Tracking Visual Indicator → [Camera][Madai] Visual Design Face Tracking Visual Indicator
This landed as par of bug 966828
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.