Closed Bug 971562 Opened 8 years ago Closed 8 years ago

mach fails to run entire xpcshell test suite

Categories

(Testing :: XPCShell Harness, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 970302

People

(Reporter: markh, Unassigned)

References

Details

Attachments

(1 file)

Bug 968581 broke the ability for mach to run the entire xpcshell test suite.  It turns out that the |manifest| param to the _run_xpcshell_harness method may be either a string (with the path to a manifest file) or a TestManifest object (or None) - but the patch in 968581 fails when it is the string.

It seems somewhat strange that things would be implemented this way, but I'm assuming this is by design, so I'm attaching a patch that just checks the type of the manifest object.

The problem causes the following output when "./mach xpcshell-test" runs:

"""
From _tests: Kept 12898 existing; Added/updated 12; Removed 0 files and 2 directories.
Error running mach:

    ['xpcshell-test']
...
AttributeError: 'unicode' object has no attribute 'test_paths'

  File "o:\src\mozilla-git\gecko-dev\testing/xpcshell/mach_commands.py", line 333, in run_xpcshell_test
    return xpcshell.run_test(**params)
  File "o:\src\mozilla-git\gecko-dev\testing/xpcshell/mach_commands.py", line 74, in run_test
    rerun_failures=rerun_failures)
  File "o:\src\mozilla-git\gecko-dev\testing/xpcshell/mach_commands.py", line 52, in run_suite
    return self._run_xpcshell_harness(manifest=manifest, **kwargs)
  File "o:\src\mozilla-git\gecko-dev\testing/xpcshell/mach_commands.py", line 124, in _run_xpcshell_harness
    verbose_output = test_path is not None or (manifest and len(manifest.test_paths())==1)

"""
Attachment #8374634 - Flags: review?(gps)
I prefer the solution in bug 970302.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 970302
Attachment #8374634 - Flags: review?(gps)
You need to log in before you can comment on or make changes to this bug.