*.wbmp file should be allowed to add in the attachment when compose an mms

RESOLVED WONTFIX

Status

Firefox OS
Gaia::SMS
P1
blocker
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: 田旻, Unassigned)

Tracking

({feature})

unspecified
Other
Gonk (Firefox OS)
feature

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22

Steps to reproduce:

When I compose an mms, I find the *.wbmp type file can't be displayed in the selected list. While this type of file is required be added in mms attachment in most area by vendors. We can't waive it any more. 


Actual results:

WBMP file can't be added in mms, which will lead our phone can't pass certification.


Expected results:

WBMP file could be added in the mms.
(Reporter)

Updated

4 years ago
Severity: normal → blocker
blocking-b2g: --- → 1.3?
OS: All → Gonk (Firefox OS)
Priority: -- → P1
Hardware: All → Other
We moved the wbmp decoder from gecko to message app only, so it's not possible to see wbmp image inside gallery app. However, you could still received a mms contains wbmp image and display/forward it. Ni? to PMs
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(jcheng)
Note: Please ref bug 882526 and bug 887164 for more information.
(Reporter)

Comment 3

4 years ago
(In reply to Steve Chung [:steveck] from comment #1)
> We moved the wbmp decoder from gecko to message app only, so it's not
> possible to see wbmp image inside gallery app. However, you could still
> received a mms contains wbmp image and display/forward it. Ni? to PMs

That's not enough. We not only need receive a WBMP file, but also need send a WBMP file via mms.
Can I ask why it's needed? Because WBMP is quite an obsolete format, specially suited to old monochrome feature phones... I understand why it's needed to display it (because other phones might send some to us) but not why it's needed do send it.
(In reply to 田旻 from comment #3)
> (In reply to Steve Chung [:steveck] from comment #1)
> > We moved the wbmp decoder from gecko to message app only, so it's not
> > possible to see wbmp image inside gallery app. However, you could still
> > received a mms contains wbmp image and display/forward it. Ni? to PMs
> 
> That's not enough. We not only need receive a WBMP file, but also need send
> a WBMP file via mms.

base on comment 2, "you could still received a mms contains wbmp image and display/forward it". it's just that you need to do it from the message app itself. I wonder if this is some MMS certification requirement? can you point us to the requirement? thanks
Flags: needinfo?(jcheng) → needinfo?(tianm)
triage: minus for now base on comment 1 & 4
blocking-b2g: 1.3? → -
(Reporter)

Comment 7

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #6)
> triage: minus for now base on comment 1 & 4
Dear Joe Cheng,

I don't think it's very proper to degrade this problem. It will lead our failure of certification and our vendors will reject our product for this single reason.
Flags: needinfo?(tianm)

Comment 8

4 years ago
Hi Joe, Vance,

I must persist in having wbmp supported in v1.3 because it's a blocker of PTCRB. TCL has applied waive request for FFv1.1 and permited but the certification organization won't agree to waive again. 

Thanks for your understanding.

Jack
blocking-b2g: - → 1.3?
Flags: needinfo?(vchen)
Flags: needinfo?(jcheng)
Created attachment 8376090 [details]
wbmp test case.png

Add the MMS conformance test case for wbmp from the OMA MMS document OMA-ETS-MMS_CON-V1_3-20080128-C.

Indeed in order to pass the MMS certification, the mobile phone not only need to support MT wbmp MMS, also need to support MO wbmp MMS

Thanks

Vance
Flags: needinfo?(vchen) → needinfo?(felash)
Ok, good for me then, but I don't even know where to start. I think there is some work to do and I really think it's late now as it's a new feature, you should have told us last november!

I'd say we want to display them in the gallery, so I'm redirecting to the gallery guys.

David, Dale, we have a wbmp javascript reader in [1]. It's fully tested in [2], passes jshint, and have the latest canvas optimization options. Feel free to move it to shared to reuse it.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/js/wbmp.js
[2] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/test/unit/wbmp_test.js
Component: Gaia::SMS → Gaia::Gallery
Flags: needinfo?(felash)
Flags: needinfo?(dflanagan)
Flags: needinfo?(dale)
TCL - Was this working previously? Specifically, does this reproduce on a Buri 1.1 device?
Flags: needinfo?(sync-1)
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Ok, good for me then, but I don't even know where to start. I think there is
> some work to do and I really think it's late now as it's a new feature, you
> should have told us last november!
> 
> I'd say we want to display them in the gallery, so I'm redirecting to the
> gallery guys.
> 
> David, Dale, we have a wbmp javascript reader in [1]. It's fully tested in
> [2], passes jshint, and have the latest canvas optimization options. Feel
> free to move it to shared to reuse it.
> 
> [1] https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/js/wbmp.js
> [2]
> https://github.com/mozilla-b2g/gaia/blob/master/apps/sms/test/unit/wbmp_test.
> js

Before we jump into implementation discussion here, let me discuss some options with the product team.
Not on media
Flags: needinfo?(dale)
I won't modify the Gallery app to support one-off image formats that gecko does not support.  If we have wbmp support in gecko, then enabling it in Gallery will be trivial (we probably need to enable the .wbmp extension for device storage as well.)  Comment #1 indicates that we used ot have wbmp support in Gecko.  Is restoring that an option?

Note that we don't need gallery to support wbmp files. We just need some app that handles a pick activty for image/vnd.wap.wbmp and can send suitable wbmp files to the SMS app.
 
Someone (maybe TCL themselves) could write a simple app named "8BitRetro" that responds to the pick activity and uses the wbmp JS library to display previews of WBMP images, including hte 120x160 image required by the certification test case.  When the user taps on an image, it passes the image blob back to the MMS app through the pick activity.

An app like that could probably live in the marketplace and not be part of the build.

If we just need to hack something up and it is NPOTB, the Media team can probably assist. But, I'm changing the component back to SMS since there is no way I'm accepting a "support an unsupported image format" requirement for gallery.

(Does anyone even have a sample .wbmp file to attach to this bug?  I wonder what would happen if I stuck it on the sdcard of my Android phone. Would I be able to attach it to an MMS message on Android?)
Component: Gaia::Gallery → Gaia::SMS
Flags: needinfo?(dflanagan)

Updated

4 years ago
Flags: needinfo?(sync-1)

Updated

4 years ago
Keywords: feature
Noemi,

Please help set expectations within TEF on this being a new feature and will not be incorporated for 1.3.
Flags: needinfo?(noef)
if this is a feature and needs more work as described by David then this should not be blocking v1.3 - we should do a plan for addressing in the future.
Flags: needinfo?(wmathanaraj)

Updated

4 years ago
blocking-b2g: 1.3? → backlog

Comment 18

4 years ago
(In reply to David Flanagan [:djf] from comment #14)
> I won't modify the Gallery app to support one-off image formats that gecko
> does not support.  If we have wbmp support in gecko, then enabling it in
> Gallery will be trivial (we probably need to enable the .wbmp extension for
> device storage as well.)  Comment #1 indicates that we used ot have wbmp
> support in Gecko.  Is restoring that an option?
> 
> Note that we don't need gallery to support wbmp files. We just need some app
> that handles a pick activty for image/vnd.wap.wbmp and can send suitable
> wbmp files to the SMS app.
>  
> Someone (maybe TCL themselves) could write a simple app named "8BitRetro"
> that responds to the pick activity and uses the wbmp JS library to display
> previews of WBMP images, including hte 120x160 image required by the
> certification test case.  When the user taps on an image, it passes the
> image blob back to the MMS app through the pick activity.
> 
> An app like that could probably live in the marketplace and not be part of
> the build.
> 
> If we just need to hack something up and it is NPOTB, the Media team can
> probably assist. But, I'm changing the component back to SMS since there is
> no way I'm accepting a "support an unsupported image format" requirement for
> gallery.
> 
> (Does anyone even have a sample .wbmp file to attach to this bug?  I wonder
> what would happen if I stuck it on the sdcard of my Android phone. Would I
> be able to attach it to an MMS message on Android?)

I test it (wbmp file) and it works well on mms of android.
(In reply to Preeti Raghunath(:Preeti) from comment #16)
> Noemi,
> 
> Please help set expectations within TEF on this being a new feature and will
> not be incorporated for 1.3.
Not a blocker for TEF. Thanks for asking.
Flags: needinfo?(noef)

Comment 20

4 years ago
Hi All, 

There is risk that DUT can't get PTCRB certification whithout wbmp MO support in MMS app.
Hi Jack, will your team able to support this feature and contribute? Thanks
Flags: needinfo?(jcheng) → needinfo?(liuyongming)

Comment 22

4 years ago
Hi Joe,

Please some one list all mozilla concerns and potential risks.

I'm afraid we can't find a reasonable solution without your help.

As I know it's not new feature request, mozilla removed it from Gecko, and if mozilla consider it's 
obsolete old format, will you take it into FirefoxOS again?

Any way, we need it to pass certification.
Flags: needinfo?(liuyongming)
Reviewing the bug tree here, I'm really confused. We supported WBMP in 1.1 with MMS for certification. So what changed here? Did we support the use case argued for in this bug in 1.1?
Flags: needinfo?(schung)
It's kind of policy that platform side strongly oppose a web platform supports non-general web image format by default. Hi SC, do you have any idea about who is the decision maker in the gecko side(Maybe Roc?)
Flags: needinfo?(schung) → needinfo?(schien)

Comment 25

4 years ago
(In reply to Jason Smith [:jsmith] from comment #23)
> Reviewing the bug tree here, I'm really confused. We supported WBMP in 1.1
> with MMS for certification. So what changed here? Did we support the use
> case argued for in this bug in 1.1?

Only support wbmp in MT MMS in 1.1, but PTCRB case requires both MT & MO support.
(In reply to Steve Chung [:steveck] from comment #24)
> It's kind of policy that platform side strongly oppose a web platform
> supports non-general web image format by default. Hi SC, do you have any
> idea about who is the decision maker in the gecko side(Maybe Roc?)

Right - it was Roc. I saw bug 882526 where gecko removed this. We instead moved it up to Gaia later in bug 887164 in 1.1.

(In reply to Jack Liu from comment #25)
> (In reply to Jason Smith [:jsmith] from comment #23)
> > Reviewing the bug tree here, I'm really confused. We supported WBMP in 1.1
> > with MMS for certification. So what changed here? Did we support the use
> > case argued for in this bug in 1.1?
> 
> Only support wbmp in MT MMS in 1.1, but PTCRB case requires both MT & MO
> support.

Okay - now I understand this. We're able to support receiving a WBMP image in a MMS message, but we can't send them in any 1.1 or later right now.
Yeah, the decision of support only MT wbmp is made by @roc in bug 882526 comment #10.
Note that Roc also specifically said that the Gallery may implement this support using the JS library.
Yes, it looks like Roc and Andreas decided 8 months ago that Gallery would use this .js library to support this image type.  Looks like I was cc'ed on the bug, but I didn't notice, so this is the first time I've every heard of this requirement.  Planning fail.

This strikes me as a completely non-trivial change to Gallery, and I really don't want to burden that app with this kind of one-off special case.

The only certification requirement here is that the MMS app can send and receive WBMP files, right?  As I understand it, MMS can already do that.  The only issue is that we need a way to demonstrate that it can send WBMP images. That means we need an app that the MMS app can attach a WBMP image from.  I don't want gallery to be that app. 

I propose that we (me if necessary, but preferably TCL engineers) write a WBMP management app and put it in the marketplace for users who want to text with their WBMP-encumbered friends.  This marketplace app would have a few built-in WBMP images (WBMP versions of emoji, perhaps?) and would support the pick activity.  If we're feeling more ambitious the app could also provide the view/open activity for this type of image and the view activity could allow the image to be saved to the sdcard or to a db so that it could be displayed in subsequent pick activities.

Here are my questions for TCL:

1) Is this idea of a special WBMP management app acceptable here?

2) Can the app be an external marketplace app or does it have to be part of the build for certification?

3) Is a static set of wbmp images sufficient? Or does the app have to be able to save and reuse received images as well?

4) Is there a TCL engineer who could implement an app like this with my guidance? (They could start by modelling it after the wallpaper app in apps/wallpaper).

Jack: if you can answer these questions (and if you can answer yet to #1) then I think we have the information we need to move forward with this.
Flags: needinfo?(liuyongming)
(Reporter)

Comment 30

4 years ago
I don't think it's a one-off special case, because it will be used for certification in 1.3 and future forever (like 1.4, 1.5 ...).
(In reply to 田旻 from comment #30)
> I don't think it's a one-off special case, because it will be used for
> certification in 1.3 and future forever (like 1.4, 1.5 ...).

What I meant by is that it is a one-off special case for Gallery to support an image format that is not supported natively.  That is what I object to.  I think that the special-purpose wbmp support app described in comment #29 should be an adequate alternative that will allow certification without burdening Gallery with the requirement to support legacy image formats that will rarely if ever be used.
Flags: needinfo?(schien)

Comment 32

4 years ago
Dear David,

Thanks for your effort of making things clear.

Here are answers for your questions:
1. I think special app for WBMP management is not friendly to users, they used to explore all images in gallery. The special app may also needs to implement many features of gallery such as share/delete, it's another gallery in the worst case.

2. It must be a builtin feature for certification purpose.

3. It should support wbmp files stored in SD card or received by MMS.

4. There is TCL engineer working on this, your guidance is definitely needed and appreciated. Whether to implement wbmp support in another app is still under discussion, but we apt to add support in gallery.
Flags: needinfo?(liuyongming)
Jack, I think David's question was really: what are exactly the certification requirements about WBMP support?
Beatriz, maybe you can help answering this?
Flags: needinfo?(brg)
(In reply to Jack Liu from comment #32)
> Dear David,
> 
> Thanks for your effort of making things clear.
> 
> Here are answers for your questions:
> 1. I think special app for WBMP management is not friendly to users, 

Do you have any user research showing that anyone (other than certification people) care about or use WBMP.  If not, I don't believe that users will actually care whether Gallery supports the image format.

they
> used to explore all images in gallery. The special app may also needs to
> implement many features of gallery such as share/delete, it's another
> gallery in the worst case.
> 
> 2. It must be a builtin feature for certification purpose.
> 
> 3. It should support wbmp files stored in SD card or received by MMS.
> 
> 4. There is TCL engineer working on this, your guidance is definitely needed
> and appreciated. Whether to implement wbmp support in another app is still
> under discussion, but we apt to add support in gallery.

I want to be very clear that I will not land WBMP support in the Gallery app without user research showing that there are actually users who will still use it after transitioning to a smart phone.

If TCL needs our help to achieve certification, we need to know the minimum requirements for certification.  I doubt that WBMP share and delete features are required, for example.
Created attachment 8379410 [details]
OMA-ETS-MMS_CON-V1_3-20080128-C.pdf
> If TCL needs our help to achieve certification, we need to know the minimum
> requirements for certification.  I doubt that WBMP share and delete features
> are required, for example.

Hi David, i just attached a MMS test spec for your reference, you can search for the word "WBMP" to find wbmp relevant test cease. For example, test case MMS-1.3-con-128 is as following

Test Case Id : MMS-1.3-con-128
Test Object : Client A
Test Case Description : The purpose is to verify that a WBMP image of the size 160x120 is correctly
sent from Client A.
Verification is done by sending the message from Client A to a test tool, which will verify that the Content type is correct and that the image file is included in its entirety in the MM sent by Client A
Specification Reference: [MMSCONF] Chapter 7
SCR Reference :MMSCONF-MED-C-011, MMSE-C-033
Tool :MMS Conformance tool
Test Code Validated test code for test case MMS-1.3-con-128
Preconditions -Client A
-
Test Procedure : 
1. In Client A, create a new MM.
2. In MM header: To-field is set to any legal address.
3. In MM content: Add image file/object WBMP_160x120.wbmp to the message.
4. In Client A, send MM to the Test Tool.
5. In the Test Tool, accept the message .
6. Verify the pass criteria below.

Pass Criteria 3GPP Client :

The MM sent by Client A has the MM PDU content type set to
application/vnd.wap.multipart.related. The MM message content shall
contain at least two parts in the MIME multipart content. One of these
parts shall have content type set to image/vnd.wap.wbmp and contain the
complete contents of the image file. A part with content type
application/smil shall also be present.

*******

So according to the test spec, the WBMP relevant test cases are only about receiving/creating a MMS which contains a WBMP file in the MMS body. Also you need to use the specific wbmp file OMA defined. It will not test share/delete/save of WBMP file from MMS, it only tests whether you can receive a MMS with WBMP, and create a MMS with WBMP as well.

That's why our partner thinks that the quickest way to pass the tests is to let Gallery app list the wbmp file in the storage(sdcard, internal moemory) such that the tester can pick the WBMP file and insert it into MMS

I totally agree with you that nowadays almost nobody using MMS any more. But still, if our partner wants to claim thier devices support MMS, they need to pass the certification, regardless it is so out-of-date and unrealistic

Hope the information helps, and please let me know shall you want to know more about MMS certification.

Vance
(Reporter)

Comment 37

4 years ago
What's more, if a WBMP picture can be added in a mms, it should possess the samilar features as other formats. If no, it will be abnormals behavior for users. Thus this kind of pictures should be viewed, saved, deleted, resized, previewed and selected as other formats. It almost contains all the features of a picture in gallery. Thus a single app is definitely not enough.  Because the activity will open a gallery app when select a picture and add in mms, I think the support of gallery is neccessary.
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #36)

Vance: thanks for this detailed information confirming the certification requirements.

> That's why our partner thinks that the quickest way to pass the tests is to
> let Gallery app list the wbmp file in the storage(sdcard, internal moemory)
> such that the tester can pick the WBMP file and insert it into MMS

Our partner may think that, but I disagree, and I think that as the author and maintainer of the Gallery app, my opinion carries more weight here.  A special purpose app could serve the same purpose (allow a tester to pick a WBMP image) without adding hard-to-maintain special case to Gallery.  Gallery works with any image format that gecko supports.  Adding WBMP support is not just a matter of adding a new image format: that would come almost for free. What is being asked here is that we make gallery display images that gecko does not believe are images, and that is a much harder proposition.

(In reply to 田旻 from comment #37)
> What's more, if a WBMP picture can be added in a mms, it should possess the
> samilar features as other formats. If no, it will be abnormals behavior for
> users. 

Normally I like to be user-centric.  In this case, however, I suggest that we remain focused on the certification issue.  Mozilla has no interest in supporting or increasing WBMP usage among our users. We only care that our MMS app can pass certification.

> Because the activity will open a gallery app when select a picture and add
> in mms, I think the support of gallery is neccessary.

When you add an attachment to an MMS, you see a list of choices that include Gallery, Camera, Music, etc.  What I am proposing is that there would be another option in the list called "Bitmaps" (or something similar).  If the user selects Gallery they'll see jpegs, gifs and pngs like they do today. If they select Bitmaps, they will see WBMP images. Tapping on one of those images would attach it to the MMS.

Creating a simple solution that will enable certification would take only a couple of days.  But I suggest that you stop thinking of this as a user-facing feature and focus on certification only.
I generally agree with all that David says. I have only one concern with adding an additional app just to pass certification. If it needs to be present in final builds (builds for users), then the user will always see it when they click on the "add attachment" button, which IMO is awkward.

I wonder if we can have slightly different builds for certification and for users.
Another idea to pass certification: use the new "Forward" capability.

* receive a MMS with a wbmp, sent by another phone
* forward that MMS to the test tool

=> victory.
(In reply to Julien Wajsberg [:julienw] from comment #40)
> Another idea to pass certification: use the new "Forward" capability.
> 
> * receive a MMS with a wbmp, sent by another phone
> * forward that MMS to the test tool
> 
> => victory.

Hi Julien, actually forward feature is a good idea, however, from my previous experience in running MMS certification, not all test house can accept this as a "PASS", some test houses ask the device to perform exactly what test case describes in order to get a PASS

And also it is not ok to run the certification with one build, but shipping with another...
> 
> Creating a simple solution that will enable certification would take only a
> couple of days.  But I suggest that you stop thinking of this as a
> user-facing feature and focus on certification only.

I totally agree with you. I think what our partner wants to achieve is to find a balance between passing the certification and providing good FFOS user experience. Offering a built-in app simply for passing the certification is to some degree not an elegant solution and will for sure cause some confusion to the end users. 

So I think what our partner suggested here is that they will modify the gallery themselves to add the wbmp support. But I am not sure if you are OK with that? if this is not OK with you, I will discuss with our partner to see if we can find other solution to for this mms certification problem

Thanks

Vance
(In reply to Julien Wajsberg [:julienw] from comment #39)
> I generally agree with all that David says. I have only one concern with
> adding an additional app just to pass certification. If it needs to be
> present in final builds (builds for users), then the user will always see it
> when they click on the "add attachment" button, which IMO is awkward.
> 
> I wonder if we can have slightly different builds for certification and for
> users.

How does the MMS app do its pick activity?  Does it include an array of mime types, or does it just leave the type field out completely?

If you list mime types, then you could modify MMS to look for an /sdcard/bitmaps/ directory. If it exists, add the WBMP mime type to the pick activity. If it does not exist, do not add it.  Alternatively, make this conditional on a setting, so that the user would have to enable WBMP support in the settings app before the MMS app would include that mime type in the pick request.
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #42)
> 
> So I think what our partner suggested here is that they will modify the
> gallery themselves to add the wbmp support. But I am not sure if you are OK
> with that? if this is not OK with you, I will discuss with our partner to
> see if we can find other solution to for this mms certification problem
> 

If they submit a patch, I will review it. But I can't imagine a way to cleanly add support for an unsupported image format. And if the patch is not incredibly clean, I won't land it because I don't want the burden of maintaining that special purpose code for years to come. Especially when I don't think it adds significant end user value.  Also, making this change will probably require gecko changes to get DeviceStorage to recognize .wbmp files as images.  And that is another can of worms: I'm not sure that is a patch that we would land either, since we don't have WBMP support in gecko.

Basically: I don't think that TCL can do this in a way that we would land.
(In reply to David Flanagan [:djf] from comment #43)
> (In reply to Julien Wajsberg [:julienw] from comment #39)
> > I generally agree with all that David says. I have only one concern with
> > adding an additional app just to pass certification. If it needs to be
> > present in final builds (builds for users), then the user will always see it
> > when they click on the "add attachment" button, which IMO is awkward.
> > 
> > I wonder if we can have slightly different builds for certification and for
> > users.
> 
> How does the MMS app do its pick activity?  Does it include an array of mime
> types, or does it just leave the type field out completely?

We use an array of mimetypes.

> 
> If you list mime types, then you could modify MMS to look for an
> /sdcard/bitmaps/ directory. If it exists, add the WBMP mime type to the pick
> activity. If it does not exist, do not add it.  Alternatively, make this
> conditional on a setting, so that the user would have to enable WBMP support
> in the settings app before the MMS app would include that mime type in the
> pick request.

Currently MMS does not use DeviceStorage at all and I'd be sad to add a permission for this. Using a pref or a setting would work for me though.

Vance, would the same build, but different prefs or settings, work ?
Flags: needinfo?(vchen)
Removing my ni, Julien question is answered by comment 35.
Flags: needinfo?(brg)
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Looks like we survived until now without this feature, closing as WONTFIX. Let's reopen or file a new bug if it's needed in the future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.