Restore Defaults should collapse Title Bar

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: pretzer, Assigned: jaws)

Tracking

(Blocks: 2 bugs)

Trunk
Firefox 30
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #966599 +++

Follow-up to bug 966599.
Just like for non-default toolbars, clicking 'Restore Defaults' should also reset the Title Bar option and collapse it, since not showing it is the default state.

Updated

4 years ago
No longer depends on: 969473
Created attachment 8376023 [details] [diff] [review]
Patch
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8376023 - Flags: review?(gijskruitbosch+bugs)
Whiteboard: [Australis:P?] → [Australis:P3]

Comment 2

4 years ago
Comment on attachment 8376023 [details] [diff] [review]
Patch

Review of attachment 8376023 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!

::: browser/components/customizableui/test/browser_970511_undo_restore_default.js
@@ +82,5 @@
> +  ok(restoreDefaultsButton.disabled, "Restore defaults button should be disabled after reset");
> +  is(titleBarButton.hasAttribute("checked"), !defaultValue, "Title bar button should reflect default value after reset");
> +  is(Services.prefs.getBoolPref(prefName), defaultValue, "Reset should reset drawInTitlebar");
> +  ok(CustomizableUI.inDefaultState, "In default state after titlebar reset");
> +

Nit: check that the undo button is shown and enabled.
Attachment #8376023 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed a follow-up to fix a CSS reference that didn't get caught when I updated the ID for the undo-reset-button.

https://hg.mozilla.org/integration/fx-team/rev/cc2833ffc0c5

Comment 5

4 years ago
https://hg.mozilla.org/mozilla-central/rev/96946c57e083
https://hg.mozilla.org/mozilla-central/rev/cc2833ffc0c5
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30

Updated

4 years ago
Blocks: 973153

Comment 6

4 years ago
Jared, was there a reason not to request aurora approval on this bug (yet) ?
Flags: needinfo?(jaws)
No reason, just been behind with travel and setting up a new machine.
Flags: needinfo?(jaws)
Created attachment 8381673 [details] [diff] [review]
Patch for Aurora

[Approval Request Comment]
Bug caused by (feature/regressing bug #): adding more functionality to restore defaults
User impact if declined: restore defaults doesn't undo titlebar changes
Testing completed (on m-c, etc.): on m-c for a while now
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8381673 - Flags: approval-mozilla-aurora?
status-firefox29: --- → affected
status-firefox30: --- → fixed
Attachment #8381673 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Mac OS X 10.9, Windows 7 64bit and  Ubuntu 12.04 using:
- latest Aurora 29.0a2 (build ID: 20140314004001)
- latest Nightly 30.0a1 (build ID: 20140314030202)
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.