[tarako] It took more than 30s for the calling screen appear when MT calls comes while playing video

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: angelc04, Unassigned)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

STR:
1. Launch Video
2. Select a video which can last longer than 1min
3. Play the vieo
4. Make a MT call to the test device and wait
   --> It took very long time for the calling screen appears. And Video app is stopped when ringtone sounds.


Recieving MT calls when play music have similiar behavior.

Comment 1

5 years ago
Peipei, could you confirm if you can still reproduce the bug with the latest build?
Flags: needinfo?(pcheng)
I tested on build 20140310152650. The calling screen on MT device can appear within three ring sounds on MO device for both Music and Video. I think this is acceptable now.

But there are some other issues, which I will file another bug to follow up.
For Video, video app is stopped when ringtone sounds.
For Music, dial screen appears as incoming all the time.
Flags: needinfo?(pcheng)

Comment 3

5 years ago
Nominating, as this can cause the receiver to miss a call when they are listening to music.
blocking-b2g: --- → 1.3T?
pcheng, can you please file and nominate the 2 bugs, we will triage in the new bugs. thanks 

>But there are some other issues, which I will file another bug to follow up.
>For Video, video app is stopped when ringtone sounds.
>For Music, dial screen appears as incoming all the time.
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → -
Last Resolved: 5 years ago
Flags: needinfo?(pcheng)
Resolution: --- → WORKSFORME
(In reply to Joe Cheng [:jcheng] from comment #4)
> pcheng, can you please file and nominate the 2 bugs, we will triage in the
> new bugs. thanks 
> 
> >But there are some other issues, which I will file another bug to follow up.
> >For Video, video app is stopped when ringtone sounds.
I filed Bug 983588.
> >For Music, dial screen appears as incoming all the time.
This is caused by Bug 982007
Flags: needinfo?(pcheng)
You need to log in before you can comment on or make changes to this bug.