Closed Bug 971705 Opened 6 years ago Closed 6 years ago

Fix Australis' panel's mainViewObserver to be disconnected on popuphidden

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox29 --- fixed
firefox30 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P3][qa-])

Attachments

(1 file)

... because observing all those changes all the time is a little over-the-top.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Comment on attachment 8374816 [details] [diff] [review]
fix Australis' panel's mainViewObserver to disconnect on popuphidden,

Review of attachment 8374816 [details] [diff] [review]:
-----------------------------------------------------------------

Yep, this looks like the right thing to do. Thanks Gijs!
Attachment #8374816 - Flags: review?(mconley) → review+
remote:   https://hg.mozilla.org/integration/fx-team/rev/113b3bb5ba8c
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5f3546636bcc
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 30
Comment on attachment 8374816 [details] [diff] [review]
fix Australis' panel's mainViewObserver to disconnect on popuphidden,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: slight perf impact, can't land bug 969376
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #8374816 - Flags: approval-mozilla-aurora?
Attachment #8374816 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [Australis:P3] → [Australis:P3][qa-]
You need to log in before you can comment on or make changes to this bug.