Back button is inconsistent

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

27 Branch
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Android; Tablet; rv:28.0) Gecko/28.0 Firefox/28.0 (Nightly/Aurora)
Build ID: 20140203224136

Steps to reproduce:

two different things (took a while to figure out):
1. from a web page, open a link in a new tab
2. switch to the new tab
3. hit back button

second:
1. open a link in a new tab
2. close the current tab
3. switch to new tab
4. hit the back button


Actual results:

in the first scenario, it switches to the original tab and closes the new tab.

in the second scenario, it leaves the new tab open and closes Firefox


Expected results:

both scenarios should have closed the new tab. the second scenario should have switched to another tab if there was one or to the home tab otherwise.
In the second scenario, tapping the back button won't close the tab because it's active. I don't think we want to close the active tab, nor do we want to open a new home:tab on back button press, but that's a UX call.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(ibarlow)
(Reporter)

Comment 2

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #1)
> In the second scenario, tapping the back button won't close the tab because
> it's active. I don't think we want to close the active tab, nor do we want
> to open a new home:tab on back button press, but that's a UX call.

Maybe instead, pop up a "toast" (tool tip) at the bottom of the sceen that has a button in it to close the tab? (similar to when you're in the gmail app and swipe to delete a message and you get a toast at the bottom with an "undo" button.

Something like:

      This is an active tab | click to close

One question: how is the new tab in the second scenario an active tab, but the new tab in the first is not? Aren't they both an active tab?

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ibarlow)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.