Keyboard settings tile slides in from the right, not the left

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: overholt, Unassigned)

Tracking

({foxfood})

unspecified
ARM
Gonk (Firefox OS)
foxfood

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Inari running local 1.3 build (gaia 14dba50b, gecko 46fdb810eb)

Settings> Keyboards > Built-in Keyboard > Back button ("<")
- "parent" panel of "Built-in Keyboard" slides in from the right, not the left as expected

(See video in URL)

All other Settings entries with multiple sub-levels use the grey box thing.  Maybe this is the problem?
Not a bug. The "settings" page you are looking at lives in the keyboard app, and the transition is reflecting that fact.

It is impossible to change it's transition without heavy modification of our window management.

ni? UX to confirm, --- for now.
blocking-b2g: 1.4? → ---
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 2

5 years ago
Flagging Omega on Settings.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(ofeng)
Created attachment 8376987 [details]
[1.4 Settings] Keyboard Settings Transition v1.0.pdf

Here is the spec for the Keyboard Settings transition.
Flags: needinfo?(ofeng)
Depends on: 1020063
Duplicate of this bug: 964868
Duplicate of this bug: 1051078
status-b2g-master: --- → affected
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-v2.5: --- → affected
Keywords: foxfood

Updated

3 years ago
status-b2g-v2.5: affected → ---

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.