Closed Bug 971745 Opened 6 years ago Closed 6 years ago

java.lang.IndexOutOfBoundsException: at java.util.LinkedList.get(LinkedList.java) in moveToParentFolder()

Categories

(Firefox for Android :: Awesomescreen, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 30
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
firefox30 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: lucasr, Assigned: lucasr)

Details

Crash Data

Attachments

(1 file)

bp-d921420f-ec6a-47ab-b2c9-f46172140211

java.lang.IndexOutOfBoundsException
	at java.util.LinkedList.get(LinkedList.java:519)
	at org.mozilla.gecko.home.BookmarksListAdapter.moveToParentFolder(BookmarksListAdapter.java:141)
	at org.mozilla.gecko.home.BookmarksListView$1.onKey(BookmarksListView.java:58)
	at android.view.View.dispatchKeyEvent(View.java:7660)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:1403)
Comment on attachment 8374861 [details] [diff] [review]
Ignore Back presses while initial bookmark list is loading (r=mfinkle)

There's a very short window of time where parent stack doesn't contain the root FolderInfo yet. This means we'll crash if the user presses the Back button before the initial list of bookmarks is loaded.
Attachment #8374861 - Flags: review?(margaret.leibovic)
Added a shorter version of the comment above to the code btw.
Crash Signature: java.lang.IndexOutOfBoundsException: at java.util.LinkedList.get(LinkedList.java)
This is a top crasher in Fx30 btw.
Attachment #8374861 - Flags: review?(margaret.leibovic) → review+
Comment on attachment 8374861 [details] [diff] [review]
Ignore Back presses while initial bookmark list is loading (r=mfinkle)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new about:home stuff in Fx26
User impact if declined: top crasher in Fx30 and likely frequent in Aurora and Beta
Testing completed (on m-c, etc.): Let's land this in nightly and gradually uplift to Aurora then Beta, keeping an eye on crash stats.
Risk to taking this patch (and alternatives if risky): Very low, one-line patch.
String or IDL/UUID changes made by this patch: n/a
Attachment #8374861 - Flags: approval-mozilla-beta?
Attachment #8374861 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/adaff41aff37
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Comment on attachment 8374861 [details] [diff] [review]
Ignore Back presses while initial bookmark list is loading (r=mfinkle)

If we want to get stats, let's land this to branches so it's in the next mobile beta (on Monday) and gets to more users for better feedback.
Attachment #8374861 - Flags: approval-mozilla-beta?
Attachment #8374861 - Flags: approval-mozilla-beta+
Attachment #8374861 - Flags: approval-mozilla-aurora?
Attachment #8374861 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.