Closed Bug 971896 Opened 7 years ago Closed 7 years ago

Can't move I.E. Live Gold button in Aurora 29.0a2 (2014-02-12)

Categories

(WebExtensions :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: woody.barrett, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P-])

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140212004002

Steps to reproduce:

Upgraded to the most recent version of Aurora


Actual results:

Toolbars are now fixed in place and cannot be moved.  At least one toolbar button (I.E.: Live Gold) can no longer be placed on any toolbar.  The URL window is no longer movable.  Toolbar customization has been severely limited - no group dividers and no spacers are available.  Legacy spacers and group dividers are still supported


Expected results:

New functionality should have been implemented without compromising or curtailing existing functionality.
(In reply to Woody Barrett from comment #0)
> Toolbars are now fixed in place and cannot be moved.

Toolbars were never themselves movable, as far as I know. Are you referring to tabs on bottom mode?

>  At least one toolbar
> button (I.E.: Live Gold) can no longer be placed on any toolbar.

Can you please refer me to the add-on that provides this button? Without that, I can't test what the problem is. If it was movable before I'm fairly sure it should be movable now, so this would be a bug.

> The URL window is no longer movable. Toolbar customization has been severely
> limited - no group dividers and no spacers are available.  Legacy spacers
> and group dividers are still supported
> 
> Expected results:
> 
> New functionality should have been implemented without compromising or
> curtailing existing functionality.

The problem here is that the original way this worked was hard to understand for many users. The new way is easier to work with and has less surprising behaviours (such as separating/merging certain buttons with the URL bar or not depending on whether (sometimes invisible) things were inbetween.

We consciously chose to make the interface more accessible, and removed some things which were a lot harder to make intuitive (such as separators and flexible spaces, and 'magical' buttons). This way, more people can make Firefox their own.

If you would like to get some of this functionality back, I'd recommend looking at our add-on ecosystem. Many add-ons re-add some or all of the functionality that we removed. One example is https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/ .

I'm morphing this bugreport to be about the button you mentioned. We'll do our best to fix that (assuming it's a bug in Firefox itself) as soon as we have details about the add-on in question. Thank you for letting us know!
Flags: needinfo?(woody.barrett)
Summary: Toolbars / Toolbar Buttons in Aurora 29.0a2 (2014-02-12) → Can't move I.E. Live Gold button in Aurora 29.0a2 (2014-02-12)
>Toolbars were never themselves movable, as far as I know. Are you referring to tabs on bottom mode?
Well, not at the bottom of the webpage window, no.  I had the tab bar located just above the page window for years, until the current Aurora iteration.

>Can you please refer me to the add-on that provides this button?
>We'll do our best to fix that (assuming it's a bug in Firefox itself) as soon as we have details
Live Gold is the name of the add-on.  It may be a problem with the way he has the button coded and I have submitted a comment about it in the add-on and extensions page - the programmer has no bug reporting page as far as I know.

>We consciously chose to make the interface more accessible, and removed some things which were a lot harder to make
>intuitive (such as separators and flexible spaces, and 'magical' buttons). This way, more people can make Firefox
>their own.
I appreciate that but, for those of us who figured out how to use those things, it presents some challenges.  For example, I prefer the toolbar / menu interface and generally set up the toolbar for those things I want to access in one click.  I also prefer to put everything on the menu bar, including the URL window which is now immovable.  Unfortunately, the menu itself is also immovable, so I can't combine one with the other and, since I need both, I can't turn either off.

>Many add-ons re-add some or all of the functionality that we removed.
Yes, I'm a big fan of Status-4-Evar.  
I will check out the link and see if I can't make this version of Aurora work for me.
Flags: needinfo?(woody.barrett)
Alrighty, then.

CTR, after some effort, allowed me to get my interface almost back to normal.  By freeing up the URL window, I was able to put it back where I had it and hide the navigation toolbar which put the tab bar back at the top of the webpage window by default.  The Live Gold icon remains stubbornly un-placeable. Also, for some reason, the menu on the menu bar is moved over about an inch.  I will have to submit a bug report to the CTR developer on that.

CTR provided an add-on toolbar that lives at the bottom of the screen like the status bar.  To avoid possible conflicts, I've disabled Status-4-Evar and placed my status bar items on the add-on bar.

Still believe you should give some thought to making the interface as flexible as possible.
The only "Live Gold" addon I can find on AMO is https://addons.mozilla.org/en-US/firefox/addon/live-gold/

Is that the addon you're talking about? As Gijs noted, unless we know exactly what addon you're talking about, we can't investigate what's happening. Let alone fix it. If this isn't the addon, please provide a link where we can find and install it.
Flags: needinfo?(woody.barrett)
Whiteboard: [Australis:P?]
(In reply to Justin Dolske [:Dolske] from comment #4)
> The only "Live Gold" addon I can find on AMO is
> https://addons.mozilla.org/en-US/firefox/addon/live-gold/
> 
> Is that the addon you're talking about? As Gijs noted, unless we know
> exactly what addon you're talking about, we can't investigate what's
> happening. Let alone fix it. If this isn't the addon, please provide a link
> where we can find and install it.

Yes, that's the one.

This add-on provides a toolbar button which expands out into a sort of precious metal dashboard so you can see prices and movement at a glance.  Unfortunately, as I said, the new version of Aurora breaks the button somehow so that it becomes unplace-able.
Flags: needinfo?(woody.barrett)
Component: Untriaged → Extension Compatibility
The statusbar element is gone because the statusbar has been removed; the toolbar item is still there (right click a toolbar, enable the "Live Gold Toolbar" to see it). However, it can't be moved to another toolbar because the add-on's toolbaritem isn't marked as removable="true". The same is the case on current release. I'm moving this to Tech Evangelism.
Status: UNCONFIRMED → NEW
Component: Extension Compatibility → Add-ons
Ever confirmed: true
Product: Firefox → Tech Evangelism
Whiteboard: [Australis:P?] → [Australis:P-]
Version: 29 Branch → Trunk
Yes, I'm using the toolbar as a work-around.

So, basically you're saying that the button doesn't work because the button is designed for the status bar and can't just be placed on any toolbar?  I do know that the Status-4-Evar add-on doesn't create a true status bar but the two add-ons were working well together until this latest Aurora release.
I sent a message to the developers. However, I wouldn't hold my breath since the add-on hasn't been touched in years. We will probably need to mark it as incompatible.
Yeah, I noticed that and I also haven't received any reply to my email, sent several days ago.  Perhaps it's time to find another add-on ...
Unfortunately, there is no acceptable alternative to Live Gold.  I found something called Metals Watcher(https://addons.mozilla.org/en-US/firefox/addon/metal-watcher/?src=search) but it appears to have been abandoned longer than Live Gold.
The add-ons have been marked as incompatible. That's as much as we can do.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Thanks, anyway.  Little can be done, at least by myself.  The license says that the code can be modified by others but I've got no JAVA and little understanding of the Firefox programming interface.  It would take more time than I have just to figure out what to do and how to do it.  The license does say that the code can be modified, though.  Love to be able to do it.
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.