If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unsupported mime & file type in 32 bit Firefox

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Phil, Unassigned)

Tracking

30 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

Steps to reproduce:

Go to this page in 32 bit mac core duo & opening video does not work. It WORKS on Google Chrome on the 32 bit core duo.

http://www.cheltenhamlittleleague.org/

It works on 64 bit macs. Also does not work on TFF on PPC machines.


Actual results:

black box with error info.


Expected results:

video should play.......take me out to the ball game.
(Reporter)

Comment 1

4 years ago
It works fine on Linux Mint 15 Firefox 27 on the 32 bit core duo....go figure.
(Reporter)

Updated

4 years ago
Severity: normal → major
Version: 27 Branch → 30 Branch
(Reporter)

Comment 2

4 years ago
This works on Safari also.
Priority: -- → P3
Thank you for your report.
It doesn't work for me both on 32/64 bit mode, FF 30.0a1(2014-02-25), Mac OS X 10.8.5.
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Product: Firefox → Core
This is not using plugins but a video element for me (source type "audio/wav" & "video/mp4"). It shows a placeholder saying "No video with supported format and MIME type found".

Per the docs on supported media formats [1] i assume there simply is no 3rd party decoder available.

https://developer.mozilla.org/de/docs/HTML/Supported_media_formats#MP4_H.264_%28AAC_or_MP3%29
Severity: major → normal
Component: Plug-ins → Video/Audio
Priority: P3 → --
(Reporter)

Comment 5

4 years ago
Quicktime plugin 7.7.1 on Lion 64 works as well as QT plugin 7.6.6 on SL 64, OT 7.6.6 on SL 32 DOESN'T....go figure!
Can you be a little more specific on the actual problem?
I do only see video tag usage on the site, and not something that would be handled by plugins.
(Reporter)

Comment 7

4 years ago
When I'm on a 64 bit macbook with the QT plugin (7.7.1 on osx 10.7.5 or 7.6.6 on osx 10.6.8) set to always activate the "take me out to the ballgame" video will play. When I set the QT plugin to never activate the video does not play(gray box on QT 7.7.1., gray box with plugin disabled on QT 7.6.6). Only QT is required on the 64 bit machines, it runs with Flip-4-mac as well as Perian disabled. It never plays on the 32 bit macbook with the QT 7.6.6 plugin set to always activate.
(Reporter)

Comment 8

4 years ago
...& when the video is playing, Activity Monitor shows it's being played with the Nightly/Firefox QT plugin.
(Reporter)

Comment 9

4 years ago
Website has removed the culprit video. Might as well close this bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.