Closed Bug 972104 Opened 11 years ago Closed 11 years ago

loses my unsaved mediawiki (wikipedia, etc.) edits on crash

Categories

(Firefox :: Session Restore, defect)

24 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 624661

People

(Reporter: naesten, Unassigned)

References

Details

(Keywords: dataloss)

(Apologies if someone has reported this already. I tried to search Bugzilla, but that's not easy.)

If Firefox crashes[1] in while I am in the midst of editing a page on a mediawiki-based wiki, Session Restore usually fails to restore my edited wikitext even to the most-recently-previewed version.  It's getting quite vexing; I'm beginning to contemplate installing Lazarus again.

When I mentioned my frustration in #mediawiki, they mentioned that this might be related to the "Warn me when I leave an edit page with unsaved changes" feature, which I *could* turn off, but I'm not sure I want to.  (Unfortunately their Bugzilla is down for maintenance, so I can't search for information about this there.)

Also note that this is *not* because other people have edited those pages, because I've checked history and found that nobody else had touched the page since I last saved it.

Actually, I strongly suspect that I'm suffering from Bug 624661: I could easily be clicking Preview, then wandering off without making any additional changes.

[1] In reality, I mostly kill it manually, but this shouldn't be relevant to Session Restore.
Depends on: 624661
Keywords: dataloss
Marking as a duplicate of bug 624661 until you can show it's not caused by that :)
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.