Closed Bug 972128 Opened 6 years ago Closed 5 years ago

[B2G][Gaia][FTE] The user can access a search bar in the privacy settings for the marketplace during the FTE

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.2 affected, b2g-v1.3 affected, b2g-v2.1 affected)

RESOLVED DUPLICATE of bug 1088461
Tracking Status
b2g-v1.2 --- affected
b2g-v1.3 --- affected
b2g-v2.1 --- affected

People

(Reporter: lmauritson, Unassigned)

References

Details

(Whiteboard: burirun1.3-3, [2.1-exploratory])

Attachments

(1 file)

Attached file log.txt
Description:
During the FTE links to privacy settings are displayed which the user can select. If selected the user can select privacy settings for the marketplace where a search bar is also displayed. The user can search for and install apps, as well as bring down the notification windows. After enough activity some buttons will become unresponsive throughout the rest of the FTE.

Repro Steps:
1) Update a Buri to BuildID: 20140212004003
2) During the FTE enable data or Wifi
3) Continue to the "Enable Geolocation" page
4) Select "More about your privacy" then "Marketplace"
5) Once the next page loads use the search bar to search for and install apps.
6) Attempt to launch several apps as well as bring down the notification bar and tapping the settings gear button.

Actual:
After enough activity some buttons will become unresponsive throughout the rest of the FTE, potentially soft locking the user. (See video) Sometimes the app will actually open and the rest of the FTE will be skipped.

Expected:
The search bar does not appear when viewing privacy settings for the marketplace during the FTE.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140212004003
Gaia: ce17d5eae7b1893ae4397c814b10ae598fcbdb58
Gecko: ab07e61c2eb0
Version: 28.0
Firmware Version: v1.2-device.cfg

Keywords: FTU, First Time Experience, soft lock, 

Repro frequency: 100%
 
See video: http://youtu.be/AbakwuKE8AE
The search bar is also present in 1.2

1.2 Environmental Variables:
Device: Buri 1.2 COM
BuildID: 20140210004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 2673f348598c
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: v1.2-device.cfg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: burirun1.3-3 → burirun1.3-3, [2.1-exploratory]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
This is another case of the FTU not being a modal experience. We linked to hosted web content for the privacy policies (as well as for contacts import and other links found in the FTU), where the user can get off-track from what is intended to be a linear setup experience. Bad things can happen and we need a strategy to fix it. In this case maybe we can tailor the marketplace page to this use-case. But there are other cases where its a 3rd party and not a practical/scalable approach.
Duplicate of this bug: 1089497
Duping against bug 1088461, which we'll use as the bug to address these kinds of 'escape/bypass' the FTU via the browser
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1088461
You need to log in before you can comment on or make changes to this bug.