Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Australis pinned tabs break toolbar interface at small window sizes

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Boriss, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 30
Points:
---

Firefox Tracking Flags

(firefox29 verified, firefox30 verified)

Details

(Whiteboard: [Australis:P3-])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8375252 [details]
Screenshot: Small window with pinned tabs showing interface errors

When multiple pinned tabs are present in an OSX Australis window, visual clipping and artifacts appear in the toolbar UI.  

There's three separate points of interface fail (see attached):

a. Misaligned pinned tab
b. Overlap of fullsize and new tab button
C. Misaligned favicons

Steps to reproduce:

1. On OSX, create at least 5 pinned tabs in one window
2. Reduce the window size
(Reporter)

Updated

4 years ago
Attachment #8375252 - Attachment description: pinned_tabs_bug2.png → Screenshot: Small window with pinned tabs showing interface errors
Flags: needinfo?(mconley)
Is this even an Australis regression?
(Assignee)

Comment 2

4 years ago
(In reply to Dão Gottwald [:dao] from comment #1)
> Is this even an Australis regression?

At least on OS X it is, apart from the weird overflow UI which all overlaps, even on holly. Everything else is tabsintitlebar related. Considering we used to only do this in maximized mode on Windows, it would have been a lot harder to hit there. Don't know if (parts of) this bug even reproduce(s) on Windows in the first place.
Created attachment 8376532 [details]
Button mess

I can't reproduce the  tab/icon problem in the screenshot ("a" and "c").

But I do get the New Tab and All Tabs buttons sliding over the next/previous tab overflow arrows, and if the window gets a bit smaller still the Fullscreen window button with slide over that mess as well.
Calling this P3- because while breaking primary UI is terrible, it's OS X only (?) and I'd tend to think that people will keep windows with pinned tabs fairly large (as opposed to a problem with popup windows, which tend to be small).
Whiteboard: [Australis:P?] → [Australis:P3-]
(Assignee)

Comment 5

3 years ago
This reproduces on WinXP in Australis. Fixing (a) and (c) is not hard, patch coming up presto. I think (b) is pre-Australis, and once we fix (a) and (c) that can be lower priority.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(mconley)
OS: Mac OS X → All
Hardware: x86_64 → All
(Assignee)

Comment 6

3 years ago
Created attachment 8384590 [details] [diff] [review]
fix tabbrowser-tabs min-height for Australis so it doesn't get squashed when the non-abs-pos bits have 0 width,
Attachment #8384590 - Flags: review?(mconley)
Comment on attachment 8384590 [details] [diff] [review]
fix tabbrowser-tabs min-height for Australis so it doesn't get squashed when the non-abs-pos bits have 0 width,

Review of attachment 8384590 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense to me. Thanks Gijs!
Attachment #8384590 - Flags: review?(mconley) → review+
(Assignee)

Comment 8

3 years ago
remote:   https://hg.mozilla.org/integration/fx-team/rev/9a9f7dd350aa
status-firefox29: --- → affected
status-firefox30: --- → fixed
Whiteboard: [Australis:P3-] → [Australis:P3-][fixed-in-fx-team]
(Assignee)

Comment 9

3 years ago
Filed bug 978835 for (b), so we can close this when the fix merges, uplifts etc.
https://hg.mozilla.org/mozilla-central/rev/9a9f7dd350aa
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3-][fixed-in-fx-team] → [Australis:P3-]
Target Milestone: --- → Firefox 30
(Assignee)

Comment 11

3 years ago
Comment on attachment 8384590 [details] [diff] [review]
fix tabbrowser-tabs min-height for Australis so it doesn't get squashed when the non-abs-pos bits have 0 width,

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis
User impact if declined: window goes wonky when small and only a few pinned tabs are left
Testing completed (on m-c, etc.): on m-c, local
Risk to taking this patch (and alternatives if risky): very low - localized change that changes tabstrip height to match tabs
String or IDL/UUID changes made by this patch: none
Attachment #8384590 - Flags: approval-mozilla-aurora?
Attachment #8384590 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

3 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/56fdd858c8ce
status-firefox29: affected → fixed

Updated

3 years ago
QA Contact: cornel.ionce
Verified that first issue is no longer reproducing on Windows 7 64 bit, Mac OS X 10.9 and Ubuntu 12.04 using:
- latest Nightly (build ID: 20140313030202).
- latest Aurora (build ID: 20140313004000).

Marking verified as bug 978835 was filled for the remaining issue.
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
You need to log in before you can comment on or make changes to this bug.