[Sora][Wi-Fi]DUT connect the AP not smoothly through the "AP Pin connetion"

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

({feature})

unspecified
feature

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: [priority])

Attachments

(1 attachment)

107.19 KB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Mozilla build ID: 20140208004002
 Created an attachment (id=626754)
 Refer this attachments
 
 DEFECT DESCRIPTION:
  DUT connect the AP not smoothly through the "AP Pin connetion".
 (Note : BETTLE Lite FF don't have this choice)
  REPRODUCING PROCEDURES:
  1,Home->Setting->enable Wi-Fi
  2,Tap the "Connect with WPS"->Choose the "AP Pin connection" 
  3,Input the PIN "82499082" -->Tap "OK"->DUT connect the AP not smoothly  through the "AP Pin connetion". -->KO 
  EXPECTED BEHAVIOUR:
 DUT connect the AP smoothly through the "AP Pin connetion".
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:9/10
 
  For FT PR, Please list reference mobile's behavior:
 
  TEL:7035
(Reporter)

Comment 1

5 years ago
Created attachment 8375278 [details]
Refer this attachments
What is meant here by not smoothly? I don't understand.
(Reporter)

Comment 3

5 years ago
(In reply to comment #1)
 > Comment from Mozilla:What is meant here by not smoothly? I don't understand.
 > 
 
 it means connection always fail. 
 
 From the log, authentication always fail and PIN registration with the AP is not successful.
AP Pin is not supported due to compatibility issues we are not able to identify and test, per bug 834114.
(Reporter)

Comment 5

5 years ago
(In reply to comment #3)
 > Comment from Mozilla:AP Pin is not supported due to compatibility issues we are
 > not able to identify and test, per bug 834114.
 > 
 when will it be supported on soul3.5? Do you have a plan with this?
(In reply to sync-1 from comment #5)
> (In reply to comment #3)
>  > Comment from Mozilla:AP Pin is not supported due to compatibility issues
> we are
>  > not able to identify and test, per bug 834114.
>  > 
>  when will it be supported on soul3.5? Do you have a plan with this?

As I know, we don't have plan on AP Pin mostly because we don't have the standard environment to verify the result.

Maybe you can help us by taking this bug if you have the ability to verify.

Comment 7

5 years ago
> As I know, we don't have plan on AP Pin mostly because we don't have the
> standard environment to verify the result.
> 
> Maybe you can help us by taking this bug if you have the ability to verify.

what's the standard environment you mentioned? Most Wireless Routers have their own WPS PIN number and STA should connect AP using this pin successfully.

Updated

5 years ago
blocking-b2g: --- → 1.3?
(In reply to buri.blff from comment #7)
> > As I know, we don't have plan on AP Pin mostly because we don't have the
> > standard environment to verify the result.
> > 
> > Maybe you can help us by taking this bug if you have the ability to verify.
> 
> what's the standard environment you mentioned? Most Wireless Routers have
> their own WPS PIN number and STA should connect AP using this pin
> successfully.

Ideally, it should be tested with an AP with WPS certification from Wifi Alliance.
And we got an AP says supporting AP Pin but actually not.
The situation is, as in bug 834114, we control wpa_supplicant as it suggested, but someone says it doesn't work while someone says it does.

We don't have the resource to handle such compatibility issue involving different APs among different phones, also, WPS is not necessary for connecting Wifi.
So we decide not to support AP Pin since then.

Comment 9

5 years ago
This is a feature. As I know, we don't have a plan for this now and it is removed from 1.1. ni? ravi.
Flags: needinfo?(rdandu)
Not blocking. This is not a committed feature for 1.3 for partners.
blocking-b2g: 1.3? → -
Keywords: feature

Comment 11

5 years ago
Ken, can this be fixed for 1.4 or 2.0
Flags: needinfo?(rdandu) → needinfo?(kchang)

Comment 12

5 years ago
We don't have plan to fix this bug, since it is a very minor feature. And some devices don't support this either.
Flags: needinfo?(kchang)

Comment 13

5 years ago
I think we should remove it from setting app. Ivan, need your help to find someone to do this in the future.
Component: Wifi → Gaia::Settings
Flags: needinfo?(itsay)

Comment 14

5 years ago
Ni Howie for the arrangement.

Howie,

This is the request from RIL team on settings. Please check if this minor feature can be arranged in the future.
Flags: needinfo?(itsay) → needinfo?(hochang)

Comment 15

5 years ago
put priority tag for future work & tracking
blocking-b2g: - → backlog
Flags: needinfo?(hochang)
Whiteboard: [priority]
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 16

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.