[Tarako] Cannot remove messages in Message app

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: atsai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [demo])

(Reporter)

Description

5 years ago
** The case is by the testing on Tarako devices. It might not be able to reproduce on other mobile devices **

As a user, I should be able to remove messages I received.

STR:
1. Send a message to self
2. Tap on the edit button
3. Select all messages by "select all" button
4. Tap on "delete"

Expected Result:
*. Messages is deleted with confirmation

Actual Result:
*. Nothing happens

BUILDID: 20140213065313 from TWCI
(Reporter)

Comment 1

5 years ago
Double click on delete button. There will be the same action as clicking edit button. We may need to separate the behaviour into different bug and reference it here.
(Reporter)

Updated

5 years ago
Blocks: 944457
> * Nothing happens

=> you don't even have the "deleting" dialog?

Also, it would still be useful to know whether this reproduces on other devices, hence qawanted
Keywords: qawanted
(In reply to Julien Wajsberg [:julienw] from comment #2)
> > * Nothing happens
> 
> => you don't even have the "deleting" dialog?
> 
> Also, it would still be useful to know whether this reproduces on other
> devices, hence qawanted

Works fine for me on 1.4 Buri on 2/11/2014 build.
Keywords: qawanted
(Reporter)

Comment 4

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #2)
> > * Nothing happens
> 
> => you don't even have the "deleting" dialog?
> 

No deleting, I'll stop at selecting message for deleting page.
Attach a video for more detail and clarifying.
That's really strange, this is definitely working on master gaia. Could you tell us which gaia version was being used? The internal build ID provided in comment 0 doesn't help much.
(Reporter)

Comment 7

5 years ago
Hi Gabriele,

Thanks for replying. I tested w/ Buri on master and v1.3 and they both work well.
I tested on v1.3t with Tarako device. Gecko is with local patches. I can get it later if you need it.

Gaia: 0a5b6db9aeda0d4ae71638819e897bd81c7ff839
I've just tested this scenario on the current v1.3t branch on my hamachi and it works just fine. The versions used are

gecko 864deea9694e07e113d8b1bef58a345e7988c5b6
gaia 4575261ef9f0fdb74d7324440e57797ee74fa8ca

Since you mentioned a custom gecko I fear that something might be broken in there; unfortunately we cannot help with that unless the changes are ported back into the main gecko tree.
A logcat might help as well.
ni? reporter for logcat
Flags: needinfo?(atsai)
(Reporter)

Comment 11

5 years ago
Didn't happen with the newest build. Close it as WFM
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(atsai)
Resolution: --- → WORKSFORME
clear flag
blocking-b2g: 1.3T? → ---
You need to log in before you can comment on or make changes to this bug.