TEST-UNEXPECTED-FAIL | test-tabmail-closing.js | test-tabmail-closing.js::test_opening_thread_in_tabs_closing_behaviour

RESOLVED FIXED in Thunderbird 30.0

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mkmelin, Assigned: hiro)

Tracking

({intermittent-failure})

Trunk
Thunderbird 30.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Looks like permantent orange across all platforms. starting with https://tbpl.mozilla.org/?tree=Thunderbird-Trunk&rev=b1c7e4fab606 (so likely some core change is the cause)

SUMMARY-PASS | test-tabmail-closing.js::setupModule
SUMMARY-PASS | test-tabmail-closing.js::test_closed_single_message_tab_returns_to_inbox
SUMMARY-PASS | test-tabmail-closing.js::test_does_not_go_to_opener_if_switched
SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\tabmail\test-tabmail-closing.js | test-tabmail-closing.js::test_opening_thread_in_tabs_closing_behaviour
  EXCEPTION: tab is undefined
    at: tabmail.xml line 689
       closeTab tabmail.xml 689
       test_opening_thread_in_tabs_closing_behaviour test-tabmail-closing.js 110
       Runner.prototype.wrapper frame.js 585
       Runner.prototype._runTestModule frame.js 655
       Runner.prototype.runTestModule frame.js 701
       Runner.prototype.runTestDirectory frame.js 525
       runTestDirectory frame.js 707
       Bridge.prototype._execFunction server.js 179
       Bridge.prototype.execFunction server.js 183

https://tbpl.mozilla.org/php/getParsedLog.php?id=34552225&tree=Thunderbird-Trunk&full=1
Comment hidden (Treeherder Robot)

Comment 2

5 years ago
While debugging this problem I noticed bug 971961. Not sure if it is really related.
See Also: → bug 971961
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 28

5 years ago
Created attachment 8376993 [details] [diff] [review]
Fix

This failure is caused by 
https://hg.mozilla.org/mozilla-central/rev/b57f9be43a50

We need to use keydown event to handle VK_RETURN there.
Assignee: nobody → hiikezoe
Status: NEW → ASSIGNED
Attachment #8376993 - Flags: review?(mbanner)

Comment 30

5 years ago
Nice, thanks!
See Also: bug 971961
Comment on attachment 8376993 [details] [diff] [review]
Fix

Looks good, r=Standard8. Thanks for fixing this.
Attachment #8376993 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/3346a739846b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 30.0
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 35

4 years ago
Until 2014-02-13 09:58:39 PST in Comment 5
we see the following error.
TEST-UNEXPECTED-FAIL | C:\slave\test\build\mozmill\folder-display\test-columns.js | test-columns.js::test_persist_columns_gloda_collection

It may have come back again.
I see in the latest log of |make mozmill| on my local PC, using full DEBUG build of C-C TB:

TEST-START | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/folder-display/test-columns.js | test_persist_columns_gloda_collection
Test Failure: Found visible column 'locationCol' but was expecting 'accountCol'!
desired list: threadCol,flaggedCol,subjectCol,senderCol,dateCol,accountCol
 actual list: threadCol,flaggedCol,subjectCol,senderCol,dateCol,locationCol
++DOMWINDOW == 108 (0x8beafb0) [pid = 9330] [serial = 1134] [outer = 0x3a73480]
TEST-UNEXPECTED-FAIL | /REF-COMM-CENTRAL/comm-central/mail/test/mozmill/folder-display/test-columns.js | test-columns.js::test_persist_columns_gloda_collectionw
(Reporter)

Comment 36

4 years ago
That's bug 1100534.
You need to log in before you can comment on or make changes to this bug.