[Dialer] The busy tone not is correct when device hangs up

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Dialer
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Tested (02/13/2014)
master
Gecko: 90b607e
Gaia: bb09224

Procedure:
Receive a voice call in the DuT Hang up wihthout answering

Expected result:
The caller hears the busy tone or the voicemail

Actual
The caller does not hear automatically voicemail
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.4?
can you please provide better STR?
which phone is the one that makes the MO (mobile-originated) call
which phone is the one that receives the MT (mobile-terminated) call

could this depend on the SIM/carrier configuration? can you also please verify this one a different commercial phone with the same SIMs? thanks
Flags: needinfo?(lolimartinezcr)
Keywords: qawanted
(Reporter)

Comment 2

4 years ago
Prerequisites: 
Device 1, the caller device (v1.3 installed) 
Device 2, the called device (master installed, Gecko.90b607e.Gaia.bb09224)
 
STR:
1) Device 1 calls Devices 2.
2) Device 2 doesn't take the call and directly hangs it up.

Actual result:
Device 1 is NOT notified that the call has ended and consequently no busy tone, answering machine or voicemail messages are heard. The call just keeps on ringing.

Expected result:
Device 1 is notified that the call has ended and consequently the busy tone, answering machine or voicemail messages are played.
Flags: needinfo?(lolimartinezcr)
QA Contact: ckreinbring
Unable to repro on today's build of Buri 1.3 and 1.4 mozilla RIL.  The caller receives the voicemail message immediately after the receiver hangs up the call.

1.3
Build ID: 20140221004002
Gecko: https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/e5f25becc0e7
Gaia: 8039a5cb7519adfa81677df577f494c6a4de6140
Platform Version: 28.0
Firmware Version: V1.2-device.cfg

1.4
Build ID: 20140221040202
Gecko: https://hg.mozilla.org/mozilla-central/rev/7010ab83a06e
Gaia: 35365feace970bfc51276428f40a477c9c86b7bb
Platform Version: 30.0a1
Firmware Version: V1.2-device.cfg
Keywords: qawanted
QA, can you please test again with a device using the Commercial RIL?
Keywords: qawanted
(In reply to Julien Wajsberg [:julienw] from comment #4)
> QA, can you please test again with a device using the Commercial RIL?

No. We don't have the ability to test on QC's RIL, as we do not have access to those builds.
Keywords: qawanted
Loli - We need the STR clarified here. We can't reproduce this on the Moz's side.
Flags: needinfo?(lolimartinezcr)
(Reporter)

Comment 7

4 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> Loli - We need the STR clarified here. We can't reproduce this on the Moz's
> side.

Hi Jason, You can see STR in:
https://bugzilla.mozilla.org/show_bug.cgi?id=972410#c2
Flags: needinfo?(lolimartinezcr)
(In reply to Loli from comment #7)
> (In reply to Jason Smith [:jsmith] from comment #6)
> > Loli - We need the STR clarified here. We can't reproduce this on the Moz's
> > side.
> 
> Hi Jason, You can see STR in:
> https://bugzilla.mozilla.org/show_bug.cgi?id=972410#c2

Right - but we tested that. We can't reproduce the bug with that STR.
So, how can we move forward here?
Loli - We still can't action this bug. Can you double check your STR here?
Flags: needinfo?(lolimartinezcr)
(Reporter)

Comment 11

4 years ago
Today i have tested with last version in v1.3 and v1.4 and it is working
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(lolimartinezcr)
Resolution: --- → FIXED
(Reporter)

Comment 12

4 years ago
Tested and working
Device: Hamachi
1.3
Build ID:20140304091708
Platform version 28.0
Gecko: 21d6a90
Gaia: 242e477

1.4
Build ID: 20140304082349
Platform version 30.0a1
Gecko: ffe5883
Gaia:71f78f77
Status: RESOLVED → VERIFIED

Updated

4 years ago
blocking-b2g: 1.4? → ---

Updated

4 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.