grippers not appearing under the URL field when adding text

VERIFIED FIXED in Firefox 30

Status

defect
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: azasypkin)

Tracking

({regression})

unspecified
Firefox 30
x86
Windows 8.1
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox28 unaffected, firefox29 unaffected, firefox30 affected)

Details

(Whiteboard: p=3 s=it-30c-29a-28b.2 r=ff30)

Attachments

(2 attachments)

Reporter

Description

5 years ago
When you initially add some text inside the URL text field under the Navigation App Bar, taping/double taping that text will not initiate the selection grippers. If you change focus to the website and than re-focus on the URL text field with the text that you've inserted, the grippers will appear the second time around.

This is only happening in the latest Nightly build, I couldn't reproduce it under Aurora and BETA.

- Attached an image to illustrate the issue

Steps to reproduce the issue:

1) Open fxmetro
2) Once opened, tap on the URL text field under the Navigation App Bar (the OSK should appear)
3) Starting taping on the OSK and add some random characters to the URL text field
4) Tap or double tap on the text that has been added, you should notice that the grippers are not available
5) Tap on the "X" to exit the "Search" and tap on the about:start window to move focus from the URL text field
6) Tap on the URL text field and this time the grippers will appear without any issues

Current Behavior:

- Trying to edit the text that's been added in the URL text field the first time around will not initiate the selection grippers

Expected Behavior:

- This should behave the same as Aurora/BETA. As soon as a user taps on the URL text field, a single monocle should appear. If a user double taps, the entire string should be highlighted and the grippers should appear.

Found the issue with the following builds:'

- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-03-02-01-mozilla-central/
-> I can reproduce the issue every single time

- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-00-40-02-mozilla-aurora/
-> Couldn't reproduce the issue

- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/
-> Couldn't reproduce the issue
Must be caused by something we haven't uplifted yet. Maybe bug 957646?

Updated

5 years ago
Blocks: metrobacklog, 957244
No longer blocks: metrov1backlog
Whiteboard: [triage] [defect] p=0 → [defect] p=0
Reporter

Updated

5 years ago
Keywords: regression
Confirming that regression was caused by fix for bug 957646.
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED

Updated

5 years ago
Blocks: 957646
Posted patch patch.diffSplinter Review
ChromeSelectionHandler now handles html inputs in addition to XUL's textbox. Still wondering whether we can add textbox support to Util.isTextInput though, if Util's isn't supposed to work with html only.
Attachment #8377510 - Flags: feedback?(jmathies)
Priority: -- → P2
QA Contact: kamiljoz
Whiteboard: [defect] p=0 → p=0 s=it-30c-29a-28b.2 r=ff30

Updated

5 years ago
Attachment #8377510 - Flags: feedback?(jmathies) → feedback+
Whiteboard: p=0 s=it-30c-29a-28b.2 r=ff30 → p=3 s=it-30c-29a-28b.2 r=ff30
Attachment #8377510 - Flags: review?(jmathies)

Updated

5 years ago
Attachment #8377510 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/integration/fx-team/rev/7dabe9719703
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: p=3 s=it-30c-29a-28b.2 r=ff30 → p=3 s=it-30c-29a-28b.2 r=ff30[fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7dabe9719703
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: p=3 s=it-30c-29a-28b.2 r=ff30[fixed-in-fx-team] → p=3 s=it-30c-29a-28b.2 r=ff30
Target Milestone: --- → Firefox 30
Flagged for testing and verification.
Flags: needinfo?(kamiljoz)
Reporter

Comment 9

5 years ago
Went through the following issue for verification and testing, used the following nightly build:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-20-03-02-02-mozilla-central/

Reproduced the original issue using original build that was used in comment #0:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-03-02-01-mozilla-central/

- Ensured that the original issue mentioned in comment #0 has been fixed and working correctly
- Ensured that single taping on the URL text field after adding text will display the single monocle
- Ensured that double taping on the URL text field after adding text will display both monocles and highlight the entire field
- Ensured that both monocles are displayed when initially taping on the URL text field under the Navigation App Bar
- Ensured once both monocles are displayed under the URL text field, a single tap should display the one monocle
- Ensured that you can use monocles in both situations (dual monocles/single monocle)
- Ensured that the single monocle is appearing in the correct area(s) when a user taps on the URL text field
- Ensured that taping at the end of the white space under the URL text field places the single monocle at the end of the string
- Went through the above test cases in several different variations of snapped view without any issues

There's still some issues when it comes to selecting text under the Navigation App Bar, these are being addressed in separate tickets. If interested, please take a look at Bug #957244 for text selection issues.
Status: RESOLVED → VERIFIED
Flags: needinfo?(kamiljoz)
Blocks: 971869
You need to log in before you can comment on or make changes to this bug.