Extracted js binaries from jsshell-*.zip sometimes do not have +x permissions

RESOLVED DUPLICATE of bug 971802

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 971802
4 years ago
4 years ago

People

(Reporter: gkw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64-debug/1392159968/jsshell-mac64.zip

Some recent jsshell-* binaries when downloaded from tinderbox-builds have +x capability, some don't.

Those that didn't have +x include:

1391742601
1391878201
1391910181
1392116802
1392143717
1392159968

decoder and I both hit this separately, likely on both Linux and Mac.

It will be nice to have +x on every js binary, instead of some, since it's a little strange to have an extracted binary provided by us without permissions to execute.
I just landed a fix for this on inbound today. Sorry!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 971802
You need to log in before you can comment on or make changes to this bug.