Appmenu subviews have scrollbar even when not needed

RESOLVED DUPLICATE of bug 972359

Status

()

RESOLVED DUPLICATE of bug 972359
5 years ago
5 years ago

People

(Reporter: roman.rellum, Unassigned)

Tracking

30 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140213030201

Steps to reproduce:

Recently you have changed how scrollbars are being summoned to appmenu subviews (help, history, dev tools etc) because of previous issue which I wont discuss here. That is fine... but what I don't get is why there is scrollbar now even when it is not needed.

Check this screenshot of dev tools: http://fii.cz/kehek


Actual results:

When I make margin and padding 1px or more, it seems that bottom of subview ends where Firefox window has bottom, which is correct behavior. Screenshot is here: http://fii.cz/xhpshcr

But when I change margin and padding to lower values when bottom of subview shouldn't be at bottom of Firefox window, there is scrollbar while bottom of subview could go few pixels lower and all items would fit in even without scrollbar. Screenshot here: http://fii.cz/efqckdae

Why is that?

Dev tools looks even more awkward: http://fii.cz/kehek

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972359
You need to log in before you can comment on or make changes to this bug.