mailto: Properties window persists

RESOLVED INVALID

Status

SeaMonkey
UI Design
P4
normal
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: sicking)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
found on all platforms, 2001.08.27.0x-comm bits.

1. go to any page which has a mailto: link --such a bugzilla report with more
than one comment.
2. bring up the context menu for the mailto: link and select Properties.
3. in the Properties window, click the mailto link.

result: as expected, a mail compose window comes up. however, the Properties
window persists. it continues to persist even after cancelling or sending the
mail msg. need to click its close widget to get rid of it.

this isn't a problem for http:, ftp: or even news: links in the Properties
window.
Hmm.. I didn't know that the properties window closed automatically for any 
types of links! And I don't see a reason why they should.

Gerv: what was the reason for adding that? I'd find that quite annoying that 
scripts close my dialog boxes when clicking on a link... If it looks like a 
link and smells like a link then IMHO it should be a link, not a combined link-
and-closebutton
Remember that when you click a link, the properties dialog will disappear anyway
because (on most OSes in most window managers) the window you click will come to
the front. If we didn't kill the properties dialog, then there would be a lot of
orphaned ones floating around. 

I remember we had this discussion at the time - check the uber-bug we used.

Gerv
Priority: -- → P4
Target Milestone: --- → mozilla1.0
Status: NEW → ASSIGNED
Keywords: mozilla1.0
sorry folks :(
Target Milestone: mozilla1.0 → mozilla1.1beta
Target Milestone: mozilla1.1beta → Future

Comment 4

15 years ago
I think since the 'mailto:' link is not clickable anymore in the properties
window, this bug has lost its point.

('Sorry' for what?)

Comment 5

15 years ago
This is currently not a bug (for months). And not likely to reappear.
-> INVALID
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.