URL not scrolling to the left when sliding monocle under the URL text field

RESOLVED INCOMPLETE

Status

defect
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: kjozwiak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=0)

Reporter

Description

5 years ago
When you have a longer URL and you're in snapped view, you'll be able to tap on the text field and slide the gripper to the right scrolling through the URL. If you try going back to the left, the URL will not scroll with the monocle. Users should be able to slide the monocle to the left and right moving the URL should scroll in that direction (till it reaches the end)

Video of the issue:
- http://www.youtube.com/watch?v=U3qMrX-l8tc

Steps to reproduce the issue:

1) Open fxmetro
2) Once opened, search for something using the "Search" (this will generate a long URL)
3) Once the search is completed, you should have a long URL located in the URL text field under the Navigation App Bar
4) Swipe in the desktop from the left side of the screen and snap it (should be in a 50/50 view)
5) Tap on the URL text field under the Navigation App Bar and the OSK should appear
6) Tap on the monocle and slide it to the right (the URL will scroll with the monocle)
6) Tap on the gripper and slide it to the left (the URL will NOT scroll with the monocle)

Current Behavior:

- When sliding the monocle to the left under the URL text field, the URL does not scroll like it does when you slide the monocle to the right

Expected Behavior:

- Should behave the same ways both ways, when a user slides the monocle the URL should scroll until the end has been reached

Found the issue using the following builds:
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-03-02-01-mozilla-central/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-02-13-00-40-02-mozilla-aurora/
- http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest-beta/win32/en-US/
Blocks: metrobacklog
No longer blocks: metrov1backlog
Whiteboard: [triage] [defect] p=0 → p=0
Mass close of bugs in obsolete product https://bugzilla.mozilla.org/show_bug.cgi?id=1350354
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.