Closed Bug 972554 Opened 7 years ago Closed 7 years ago

Add more things to nsIXULRuntime so we can avoid preprocessing some tests

Categories

(Toolkit :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 972555

People

(Reporter: ted, Assigned: ted)

Details

We have a handful of tests (looks like all browser-chrome) that rely on being preprocessed so they can handle a few build conditionals. I want to stop preprocessing them instead of adding preprocessing support to our test manifests, so I'd rather just stuff all the info they need on nsIXULRuntime and fix them to use that. This patch adds all the things I found in my brief survey to nsIXULRuntime. (It's possible I missed a few things and will need to add to this list later.)
Apparently bzexport filed me a dupe.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 972555
You need to log in before you can comment on or make changes to this bug.