Closed Bug 972555 Opened 6 years ago Closed 6 years ago

Add more things to nsIXULRuntime so we can avoid preprocessing some tests

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30

People

(Reporter: ted, Assigned: ted)

References

Details

Attachments

(1 file)

We have some browser-chrome tests that are currently preprocessed to get at some build conditionals. I'd like to stop preprocessing them, so this patch stuffs those conditionals on nsIXULRuntime instead.
Blocks: 968403
Attachment #8375773 - Flags: review?(benjamin)
Attachment #8375773 - Flags: review+
Don't forget to rev the UUID so you don't burn the tree.
Flags: needinfo?(ted)
Thanks for the reminder!
Flags: needinfo?(ted)
https://hg.mozilla.org/mozilla-central/rev/a34e6d5519ef
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Duplicate of this bug: 972554
You need to log in before you can comment on or make changes to this bug.