WebGL glHint doesn't MakeCurrent

RESOLVED FIXED in Firefox 29, Firefox OS v1.4

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

unspecified
mozilla30
Points:
---

Firefox Tracking Flags

(firefox27 wontfix, firefox28 wontfix, firefox29 fixed, firefox30 fixed, firefox-esr24 wontfix, b2g18 wontfix, b2g-v1.1hd wontfix, b2g-v1.2 wontfix, b2g-v1.3 wontfix, b2g-v1.3T wontfix, b2g-v1.4 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
WebGL.hint doesn't call makecurrent.
It...should.
(Assignee)

Comment 1

4 years ago
Created attachment 8375872 [details] [diff] [review]
makecur-hint
Attachment #8375872 - Flags: review?(dglastonbury)
Attachment #8375872 - Flags: review?(dglastonbury) → review+
(Assignee)

Updated

4 years ago
status-b2g18: --- → wontfix
status-b2g-v1.1hd: --- → wontfix
status-b2g-v1.2: --- → affected
status-b2g-v1.3: --- → affected
status-b2g-v1.3T: --- → affected
status-b2g-v1.4: --- → affected
status-firefox27: --- → wontfix
status-firefox28: --- → wontfix
status-firefox29: --- → affected
status-firefox30: --- → affected
status-firefox-esr24: --- → wontfix
(Assignee)

Comment 2

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/31b0e162f80e
(Assignee)

Comment 3

4 years ago
Comment on attachment 8375872 [details] [diff] [review]
makecur-hint

[Approval Request Comment]
Bug caused by (feature/regressing bug #): WebGL
User impact if declined: Nothing dangerous.
Testing completed (on m-c, etc.): Local
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8375872 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

4 years ago
status-b2g-v1.2: affected → wontfix
https://hg.mozilla.org/mozilla-central/rev/31b0e162f80e
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
Attachment #8375872 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/c67b7129565a
status-b2g-v1.3: affected → wontfix
status-b2g-v1.3T: affected → wontfix
status-b2g-v1.4: affected → fixed
status-firefox29: affected → fixed
status-firefox30: affected → fixed
You need to log in before you can comment on or make changes to this bug.