[B2G][Settings]Packaged App Poppit! displays with broken image placeholder in Settings App permissions when downloaded from Marketplace

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: mclemmons, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected, b2g-v1.4 affected, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [permafail])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8375929 [details]
Image Placeholder Broken Screenshot

User download of packaged app Poppit! from Marketplace displays properly on homescreen of device. However, during the download, when user navigates to the App permissions section within settings the Poppit! Icon doesn't display properly during or after the download.

Repro Steps:
1) Updated Buri to BuildID: 20140212004003
2) Tap Marketplace App and download Poppit!
3) While download is ongoing, tap homescreen button and tap Settings App 
4) Tap App permissions and observe the Poppit! Icon to the left of the app title

Actual:
Poppit! Icon appears as a hollow square with a piece of paper image within separated to resemble a page tear

Expected:
Poppit! Icon appears as it does on device homescreen, the word Poppit! within a blue circle with balloons above the text within the circle

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140212004003
Gaia: ce17d5eae7b1893ae4397c814b10ae598fcbdb58
Gecko: ab07e61c2eb0
Version: 28.0
Base image: v1.2-device.cfg

Other notes:
1. Repro frequency: (10/10, 100%) 
2. Link to failed test case: https://moztrap.mozilla.org/manage/case/5993/
3. See attached: screenshot
4. Another packaged App Terra doesn't demonstrate this behavior like Poppit!
(Reporter)

Comment 1

5 years ago
This issue does not reproduce on Buri 1.2. When user follows the STR from Comment 0, the expected result of a complete image of Poppit! appears in the Settings App permissions section in a similar fashion as it displays on homescreen of device. 

Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140212004000
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 4fd893896d02
Version: 26.0
This doesn't reproduce post download, so I think this is minor.
Keywords: regressionwindow-wanted

Updated

5 years ago
Duplicate of this bug: 977821
This issue occurs on Open C 1.4


1.4 Environmental Variables:
Device: Open_c 1.4 MOZ
BuildID: 20140428000206
Gaia: d23e479e8a4ce0bc620acb2d7e2f82801aa4d0ea
Gecko: 36f67ce46855
Version: 30.0a2
Firmware Version: P821A10-ENG_20140410

Link to failed test case: https://moztrap.mozilla.org/manage/case/5994/
status-b2g-v1.4: --- → affected
Whiteboard: burirun1.3-3 → burirun1.3-3 OpenCrun1.4-3

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(dharris)
Whiteboard: burirun1.3-3 OpenCrun1.4-3 → [2.1-flame-test-run-3], burirun1.3-3 OpenCrun1.4-3

Updated

4 years ago
Whiteboard: [2.1-flame-test-run-3], burirun1.3-3 OpenCrun1.4-3 → [permafail]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 5

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.