Mozillian's username invalid after change in mozillians.org

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
--
major
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Lavish Aggarwal, Assigned: tasos)

Tracking

Details

(Whiteboard: [kb=1274668] )

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8376037 [details]
Screenshot (5).png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140127194636

Steps to reproduce:

I created my account on mozillians.org [ https://mozillians.org/en-us/u/lucky.lavish ]
but after sometimes i changed it to [ https://mozillians.org/en-us/u/lavish ]  and it was successfully changed. But issue is that when i attend any event on reps.mozilla.org it shows my name as attendee over there but when i click on my name it navigate me to my older url i.e. [ https://mozillians.org/en-us/u/lucky.lavish ] which results in Page Not Found ERROR.


Actual results:

It  results in Page Not Found ERROR


Expected results:

my mozillian profile url must b updated to every url related to mozillians .org so that it navigate to correct profile
(Reporter)

Updated

4 years ago
Component: reps.mozilla.org → General
Keywords: needURLs
Product: Mozilla Reps → www.mozilla.org
Version: unspecified → Production
(Reporter)

Updated

4 years ago
Severity: normal → major

Updated

4 years ago
Component: General → reps.mozilla.org
Product: www.mozilla.org → Mozilla Reps
Version: Production → unspecified
Whiteboard: [kb=1274668]
Summary: mozillians profile link invalid when clicked on attendee on any event of reps.mozilla.org → Mozillian's username invalid after change in mozillians.org
needURLs is a crashkill keyword
Keywords: needURLs
(Assignee)

Updated

4 years ago
Assignee: nobody → tasos
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED

Comment 2

4 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/8714896af6983ef0eee0098a48bd26219b0012e3
[fix bug 972715] Update mozillian username more often.

https://github.com/mozilla/remo/commit/90344ef828613b9ba79a0f19c29255d9563cf1f0
Merge pull request #643 from akatsoulas/972715

[fix bug 972715] Update mozillian username more often.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Version: unspecified → next
(Assignee)

Comment 3

4 years ago
There was already a task in the portal which updated the database every 24 hours. The problem appeared only if a user's profile was changed during that interval. The task is now scheduled to run every 8 hours. If this is still a problem, please re-open the bug, to lower the interval more or to seek for another solution.
(Reporter)

Comment 4

4 years ago
Bug is not resolved till now... still my profile link is different on reps.mozilla.org and mozillians.org
Status: RESOLVED → REOPENED
Flags: needinfo?(tasos)
Resolution: FIXED → ---
lucky, the code linked in comment 2 will fix the issue. It will be deployed soon (this week, probably). Until then you might not see any change in your profile link.
Flags: needinfo?(tasos)
(Reporter)

Comment 6

4 years ago
Hey Justin ...  can you please elaborate and tell me what should i do to fix this bug??
lucky, please wait. It will be fixed.
(Reporter)

Comment 8

4 years ago
Justin how much time? because I'm changed my url of mozillian 1 month ago... and still its same :(
Hi Lucky, it should be fixed in the next week or so. We have fixed the issue in the code, and we will be releasing the new code to the site very soon. Thanks again for reporting and your patience as we fix the issue :)
(Reporter)

Comment 10

4 years ago
Thanks William :)
(Assignee)

Comment 11

4 years ago
The task didn't run due to this bug [1]. Now that it's resolved, I am marking this bug as resolved too.

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=977508
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

4 years ago
Verified on stage.

Verification steps:

* Log into stage server with username A
* Changed the username on mozillians.allizom.org to B
* Log into stage server with username changed to B (after 8 hours)
Status: RESOLVED → VERIFIED
Version: next → 425
You need to log in before you can comment on or make changes to this bug.