Closed Bug 972827 Opened 7 years ago Closed 6 years ago

Add hosted App - hide placeholder when user click on the URL field

Categories

(DevTools Graveyard :: WebIDE, defect)

28 Branch
defect
Not set
normal

Tracking

(firefox28 affected, firefox29 affected, firefox30- affected)

RESOLVED WONTFIX
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 - affected

People

(Reporter: svbabukumar, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

Steps to reproduce:

Steps to Reproduce:

1. Launch the browser and click on the Tools > Web developer > App Manager
2. In the bottom of the page under ensure you see the "Add Hosted App" field to enter the URL
3. Ensure there is a water mark text showing the example as http://example.com...
4. Click on the field

Expected : field should become  empty and no water mark text should display as soon as user click on the field

Actual : Even after user click on the "Add Hosted App" URl field the water mark text displays until we add another URL
I agree that in step 2, clicking in the "Add Hosted App" field should probably make the field blank, or at least select the text so it can be easily deleted. 

I'm less sure what the behavior of the watermark should be. I'd expect it to disappear once I'd selected an app, but not necessarily while I'm typing a url.
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools: App Manager
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Greyed-out text in a field doesn't disappear upon clicking, and isn't selectable; you can type over it, though.
Oh, I thought by "watermark" the original reporter meant the jetpack logo in the right-hand pane. Instead, they are referring to the greyed out text.
Summary: Add hosted App - Water mark text in the URL field should become empty when user click on the URL field → Add hosted App - hide placeholder when user click on the URL field
Will track this for now since it will have some impact on our users experience.
Without user feedback showing that this is affecting many people, we don't need to track this, and also this looks like something that needs some UX & devtools team input on what the desired behaviour should be along with resource allocation and prioritization.
Won't fix. WebIDE to the rescue.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.