Closed Bug 973071 Opened 11 years ago Closed 11 years ago

crash in mozilla::layers::Compositor::SetBackend(mozilla::layers::LayersBackend)

Categories

(Core :: Graphics: Layers, defect)

30 Branch
x86_64
Windows 8.1
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 972891
Tracking Status
firefox29 --- unaffected
firefox30 --- affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-7f4fad25-0a6f-4d1c-991a-7287f2140214.
=============================================================

STR
1. set layers.offmainthreadcomposition.enabled = true
2. Restart browser
Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b2dd850b0ca3
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213082025
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f78468f352e4
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140213085548
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b2dd850b0ca3&tochange=f78468f352e4

Triggered by:
f78468f352e4	Bill McCloskey — Bug 963952 - [e10s] Don't use basic compositor when using D3D11 compositor (r=mattwoodrow)


Graphics
--------

Adapter Description: VMware SVGA 3D
Adapter Drivers: vm3dum64 vm3dum vm3dgl64 vm3dgl
Adapter RAM: 128
Device ID: 0x0405
Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues.
DirectWrite Enabled: false (6.3.9600.16384)
Driver Date: 7-12-2013
Driver Version: 7.14.1.5025
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic Blocked for your graphics card because of unresolved driver issues.
Vendor ID: 0x15ad
WebGL Renderer: Blocked for your graphics card because of unresolved driver issues.
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0
Blocks: 963952
Fixed by backed out Bug 963952.

https://hg.mozilla.org/integration/mozilla-inbound/rev/b2fc3f9509b0
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 ID:20140214133650
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
This might be a dupe of bug 972891 but I'm not sure given the different platform. For now we kept bug 972891 open to check why specifically we had this crash. Please check the other bug in what steps to do to get the necessary information why we were crashing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Actually closing as dupe.
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.