Editor window and caret arrow problems

VERIFIED DUPLICATE of bug 95056

Status

()

Core
Selection
--
major
VERIFIED DUPLICATE of bug 95056
17 years ago
17 years ago

People

(Reporter: tomstdenis, Assigned: mjudge)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.3) Gecko/20010801
BuildID:    20010801

Ok this is driving me up a wall... I'm having problems using the arrow keys to
move around in a mail window [replying to a message window to be exact]. 
Everytime I hit "enter" to put a new line in it puts two then jumps two.  If I
hit delete it goes back where it started.

Not only that but if I copy and paste text inbetween two lines it enters a blank
line and gives the same problems.

And to top it off when I tried to scroll down to the problem area with the arrow
keys it jumps back to the top.

Essentially I dunno if my pc is messed up or if it's Mozilla but I can't use the
edit windows at all.

I've run memtest86 to see if it was my memory giving faults [happended before]
and apparently not.  Not only that but this window I am typing this into is
working just fine....

Reproducible: Always
Steps to Reproduce:
1.hit reply
2.Try to use arrow keys to move around
3.get completely annoyed

Actual Results:  cursor jumps erradically

Expected Results:  should move to where you intuiatively want it to go

Comment 1

17 years ago
Editor problem, I believe a duplicate.
Assignee: sspitzer → beppe
Component: Mail Window Front End → Composition
QA Contact: esther → sujay

Comment 2

17 years ago
----> brade
Assignee: beppe → brade

Comment 3

17 years ago
-->jfrancis
Assignee: brade → jfrancis
Summary: Editor window and cursor problems → Editor window and caret arrow problems
Sounds like it's partly covered by the following bugs:

Bug 89119
Bug 95056
Bug 97793

Anything to add?

Comment 5

17 years ago
caret movement from arrow keys is a selection issue.  stupid bugzilla is making 
this reassignment a two step process....
Component: Composition → Selection
Product: MailNews → Browser

Comment 6

17 years ago
reassigning
Assignee: jfrancis → mjudge
QA Contact: sujay → tpreston

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 7

17 years ago

*** This bug has been marked as a duplicate of 95056 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.